View Issue Details

IDProjectCategoryView StatusLast Update
0000032The Dark ModAIpublic30.04.2008 14:45
ReporterSneaksieDave Assigned Toangua  
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Fixed in VersionSVN 
Summary0000032: Loss of arm animation after wound (or alert?)
Descriptionsource:
http://modetwo.net/darkmod/index.php?s=&showtopic=5049&view=findpost&p=93649

Reproduction of this is not exactly clear yet, but it seems to happen after going alert or getting wounded. And, it happens often enough that it's easy to see. On loading warehouse 2 times and test_walk_ik once, I've had it happen each time.

See the attached movie. After putting an arrow in his back, the city guard loses his upper body (or at least the arms) animation; they're as if tied to his body, while he still walks, twists, and looks around.

http://208.49.149.118/thedarkmod/movies/armstied.wmv

His sword keeps intermittently popping out and vanishing too - maybe related?
TagsNo tags attached.

Activities

angua

angua

20.04.2008 19:32

manager   ~0001149

Haven't seen this since rewriting the AI code, so I'd call this fixed.
SneaksieDave

SneaksieDave

30.04.2008 14:45

developer   ~0001178

Looks good; will mention if I come across it again.

Issue History

Date Modified Username Field Change
23.01.2007 23:53 SneaksieDave New Issue
20.04.2008 19:32 angua Status new => resolved
20.04.2008 19:32 angua Fixed in Version => SVN
20.04.2008 19:32 angua Resolution open => fixed
20.04.2008 19:32 angua Assigned To => angua
20.04.2008 19:32 angua Note Added: 0001149
30.04.2008 14:45 SneaksieDave Status resolved => closed
30.04.2008 14:45 SneaksieDave Note Added: 0001178