View Issue Details

IDProjectCategoryView StatusLast Update
0003202The Dark ModAIpublic26.02.2013 19:07
Reportergrayman Assigned Tograyman  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003202: Mute AI can engage in greetings
DescriptionFor story purposes, an AI can be made mute.

When a mute AI encounters another AI, the mute AI will still send a greeting message, though it won't say anything.

What the player hears is the greeted AI responding, as if he was greeted. It looks odd, since the first AI didn't say anything.

The code should not let muted AI send a greeting to another AI.
TagsNo tags attached.

Activities

grayman

grayman

26.02.2013 19:07

administrator   ~0005113

Don’t let mute AI issue greetings.

Allow AI that can talk to issue greetings to mute AI.

Don’t let mute AI respond to greetings.

Fixed bug that kept AI from receiving future greetings if for some reason they were unable to respond (alert level got too high, etc.)

rev. 5702:

State.cpp
Actor.cpp
Actor.h

Issue History

Date Modified Username Field Change
15.08.2012 20:07 grayman New Issue
15.08.2012 20:07 grayman Status new => assigned
15.08.2012 20:07 grayman Assigned To => grayman
26.02.2013 19:07 grayman Note Added: 0005113
26.02.2013 19:07 grayman Status assigned => resolved
26.02.2013 19:07 grayman Resolution open => fixed
26.02.2013 19:07 grayman Fixed in Version => TDM 2.00
26.02.2013 19:07 grayman Target Version => TDM 2.00