View Issue Details

IDProjectCategoryView StatusLast Update
0003219DarkRadiantGeneralpublic27.08.2013 14:32
Reportergrayman Assigned ToSTiFU  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.7.0 
Target Version1.8.0Fixed in Version1.8.0 
Summary0003219: Preferences/Readable Editor failure
DescriptionStarting with some version after 1.7.0, the Readables Editor ignores any changes to the Preferences/Readable Editor setting.

I never tried to use this until recently, so perhaps it's been broken all along, or was never implemented.

The RE always wants to use darkmod/xdata for storage of xdata content. Changing the settings on the Preferences/Readable Editor screen has no effect, and in fact anything I type in there is ignored during the same session, and lost if I quit DR and start it up again.

As a result, when I work in a non-SVN version of the darkmod folder I get the error message (paraphrased) "You read this xdata text from a PK4, and I can't let you save it back to a PK4, so pick somewhere else to save your change."

This is a major PITA, requiring saving elsewhere and moving the changed text back to the correct xdata file by hand, subverting the reason the RE is there in the first place.
TagsNo tags attached.

Activities

STiFU

STiFU

06.09.2012 10:24

developer   ~0004794

This definitely used to work and the fact that the settings are ignored and lost upon restart of DR makes me think that those settings are never really issued to DR. Something must have changed here.

user81

12.09.2012 00:43

  ~0004825

I am also getting this when trying to create a readable on the updated version of the training mission.

- http://forums.thedarkmod.com/topic/14083-trying-to-edit-a-readable-getting-this-error/page__pid__294631#entry294631
STiFU

STiFU

06.10.2012 11:58

developer   ~0004858

I can't seem to reproduce this behaviour in 1.7.2. I am guessing the issue has already been fixed in some other context.

Here is what I do:
- Setup DR (win32) to use mod base folder for xdata storage
- Create a readable entity and fireup the readable editor
- Save some text and close the RE
- Reopen RE and everything is fine
(Make sure there is no xdata file of the same name anywhere.)
STiFU

STiFU

07.10.2012 08:53

developer   ~0004864

As I now found out, this only works as long as direct child folder of the D3 directory are used as fs_game_base and not something deeper in the directory tree. I'll see what I can do.
STiFU

STiFU

07.10.2012 11:04

developer   ~0004866

Fixed in e2eda0f1accd1e843a2e30918c954b8e3fe1a883.

user81

07.10.2012 12:01

  ~0004868

Smashing, thanks for fixing this mista!

Issue History

Date Modified Username Field Change
05.09.2012 23:03 grayman New Issue
05.09.2012 23:04 grayman Description Updated View Revisions
06.09.2012 10:24 STiFU Note Added: 0004794
12.09.2012 00:43 user81 Note Added: 0004825
06.10.2012 11:58 STiFU Note Added: 0004858
06.10.2012 11:59 STiFU Status new => feedback
06.10.2012 11:59 STiFU Resolution open => unable to reproduce
07.10.2012 08:53 STiFU Note Added: 0004864
07.10.2012 08:53 STiFU Assigned To => STiFU
07.10.2012 08:53 STiFU Status feedback => confirmed
07.10.2012 08:53 STiFU Resolution unable to reproduce => open
07.10.2012 08:53 STiFU Target Version => 1.8.0
07.10.2012 11:04 STiFU Note Added: 0004866
07.10.2012 11:04 STiFU Status confirmed => resolved
07.10.2012 11:04 STiFU Resolution open => fixed
07.10.2012 11:04 STiFU Fixed in Version => 1.8.0
07.10.2012 12:01 user81 Note Added: 0004868
27.08.2013 14:32 greebo Status resolved => closed