View Issue Details

IDProjectCategoryView StatusLast Update
0003229The Dark ModDistributionpublic11.09.2012 00:48
Reportergrayman Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003229: tdm_fonts01.pk4 is downloaded twice
Descriptiongreebo wrote this:

I debugged the updater and it seems there is a filename case problem going on. I can see that after differential update application, the tdm_fonts01.pk4 contains a folder fonts\english\lotharus, with the following contents:

fontImage12.dat
fontimage12.dat
fontImage24.dat
fontimage24.dat
fontImage48.dat
fontimage48.dat

(Note the uppercase I and lowercase i, both variants are present which is probably not intentional.)

The "proper" file as generated from the darkmod repo should contain this:

fontimage12.dat
fontimage24.dat
fontimage48.dat

which indicates that the filename case has been changed, since the differential updater adds the lowercase i, as expected, but doesn't remove the uppercase I variants. I'll look into SVN what might produce such behaviour.


TagsNo tags attached.

Activities

grayman

grayman

11.09.2012 00:48

administrator   ~0004820

greebo fixed the problem.

Issue History

Date Modified Username Field Change
09.09.2012 17:53 grayman New Issue
09.09.2012 17:53 grayman Status new => assigned
09.09.2012 17:53 grayman Assigned To => greebo
11.09.2012 00:48 grayman Note Added: 0004820
11.09.2012 00:48 grayman Status assigned => resolved
11.09.2012 00:48 grayman Resolution open => fixed
11.09.2012 00:48 grayman Fixed in Version => TDM 1.08