View Issue Details

IDProjectCategoryView StatusLast Update
0003235The Dark ModCodingpublic05.10.2012 21:32
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Summary0003235: AI not patrolling after conversation
DescriptionIn the mission In Remembrance of Him, there are two AI that play scripted "conversations" and then start a regular patrol. At least two people using 1.08 (including me) reported that the AI did not go on patrol. Yet when I tested with 1.07, they did. We need to make sure something with 1.08 isn't breaking this mission.

RPGista said: It seems that there is a problem with the very last step on the conversation of both characters, which is an "activate entity" command; it is supposed to activate a trigger, which in turn will activate a path_wait for trigger that will send them on their patrols.

TagsNo tags attached.

Activities

Springheel

Springheel

20.09.2012 01:01

administrator   ~0004841

Tried this again in 1.08, and noticed clearly that merchant's wife conversation could be triggered by going into the kitchen downstairs, and she didn't move afterwards.

In 1.07, I could not trigger the conversation until starting up the stairs, and she did patrol afterwards. Something is different.
tels

tels

23.09.2012 08:24

reporter   ~0004845

After the conversation ends, this command is executed:

Conversation Command: 'ActivateTarget' activating entity triggerwife

The trigger it activates sits at top top corner of the stairs (so theoretically, the player could also trigger it by climbing/jumping into it).

This trigger "works", e.g. after getting triggered, it vanishes. However, what it actually triggers/targets is the "merchantwife" itself.

She targets the path_corner waitfortrigger and this somehow seems not to work anymore.
tels

tels

23.09.2012 08:30

reporter   ~0004846

Last edited: 23.09.2012 10:13

View 2 revisions

Yes, you can jump into the triggerwife and activate it manually. At the end of the conversation the game then complains it can no longer find this trigger.

This is a map problem, but not actually serious.

In any event, triggering triggerwife does not result in the wife patroling, regardless on how you trigger it (player touch or conversation).

Edit: Jumping into the triggerwife does make the wife patrol as long as you haven't triggered the conversation yet. Once the conversation runs, this trigger does no longer work.

Maybe the problem here is that at the end of the conversation, this triggerwife does not work, maybe because the wife is still in the "conversation" state/task? It smells more an AI problem than a trigger problem.

Springheel

Springheel

24.09.2012 01:22

administrator   ~0004849

Last edited: 24.09.2012 01:52

View 4 revisions

I just tried it again in 1.07 multiple times and it worked properly, with the woman patrolling after she is done. I tried the same thing multiple times in 1.08 and she did not patrol. So something in 1.08 seems to be stopping the trigger from working.

  Was anything changed with trigger or conversation behaviour?

Springheel

Springheel

25.09.2012 22:13

administrator   ~0004851

This needs to be addressed on the map level.

Issue History

Date Modified Username Field Change
19.09.2012 01:03 Springheel New Issue
20.09.2012 01:01 Springheel Note Added: 0004841
23.09.2012 08:24 tels Note Added: 0004845
23.09.2012 08:30 tels Note Added: 0004846
23.09.2012 10:13 tels Note Edited: 0004846 View Revisions
24.09.2012 01:22 Springheel Note Added: 0004849
24.09.2012 01:39 Springheel Note Edited: 0004849 View Revisions
24.09.2012 01:40 Springheel Note Edited: 0004849 View Revisions
24.09.2012 01:52 Springheel Note Edited: 0004849 View Revisions
25.09.2012 22:13 Springheel Note Added: 0004851
25.09.2012 22:13 Springheel Target Version TDM 1.08 =>
25.09.2012 22:13 Springheel Assigned To => Springheel
25.09.2012 22:13 Springheel Status new => assigned
05.10.2012 21:32 Springheel Status assigned => resolved
05.10.2012 21:32 Springheel Resolution open => fixed