View Issue Details

IDProjectCategoryView StatusLast Update
0003245DarkRadiantGUIpublic27.08.2013 14:32
ReporterSTiFU Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.8.0 
Target Version1.8.0Fixed in Version1.8.0 
Summary0003245: Cancel-Button in the Preferences-dialog does not work
DescriptionThe textfields in the Preferences-dialog are directly linked to the preferences-registry, which is updated upon every change of said textfields. This leads to the Cancel-Button having no functionality and generally some undesired behavior.

This might also be the reason, why there is sometimes a big delay after entering something for instance in the game_base_path textfield.
Steps To ReproduceIn the preferences dialog edit the engine path textfield to something like ".../Doom3/d". All textures in the editor will disappear, regardless of whether you click "ok" or "cancel".
TagsNo tags attached.

Activities

greebo

greebo

12.10.2012 18:58

administrator   ~0004911

Done in commit 04f757d1de1402a45b72789954d031414eb9d4bf.
STiFU

STiFU

12.10.2012 22:39

developer   ~0004913

Just tried this in order to check whether this also fixes the issue of long delays upon entering something in the mod_base textfield, which it does, nice! However 0003242 seems to be broken now again, which also leads to the issue that the OK-button does not work in some cases (kinda funny). If there is no text in one of the textfield and you press ok, DR will hang up (tested with game and xdata storage directory).

My fix for 0003242 was adding a
entry->setValue(GlobalRegistry().get(registryKey));
to PrefPage::appendPathEntr in order to initialize it with the appropriate text.
greebo

greebo

13.10.2012 07:00

administrator   ~0004914

Can't reproduce the behaviour you described. Neither the custom xdata folder nor the game engine path entry fields are empty on a fresh start, and settings are saved alright. It's also not a problem to clear the contents of the custom xdata folder entry and hit OK. Do you have more detailed reproduction steps?
STiFU

STiFU

13.10.2012 09:14

developer   ~0004915

Last edited: 13.10.2012 09:36

View 2 revisions

This happens to me both with Win32 and x64 debug builds and also with Win32 Release build. I build with VS 2010. I even tried reseting my config, but it still happens.

The fields are empty everytime I open the preferences dialog. If I fill them with the appropriate information and press OK, everything is fine. But if I don't enter something DR hangs up.

I thought I'd look into applying my old patch, only to discover that it was still in place. Hmn... Since you can't reproduce this behaviour, could you tell me where the widget-contents are usually initialized, so that I can have a look at that with the debugger?

STiFU

STiFU

13.10.2012 09:50

developer   ~0004917

Last edited: 13.10.2012 10:09

View 2 revisions

AHA!! This issue only occurs when you've got spaces in your D3-path, i.e. "d:\games\Doom 3".

With removed spaces, my old patch even becomes obsolete.

Issue History

Date Modified Username Field Change
07.10.2012 11:42 STiFU New Issue
12.10.2012 18:16 greebo Status new => confirmed
12.10.2012 18:33 greebo Assigned To => greebo
12.10.2012 18:33 greebo Status confirmed => assigned
12.10.2012 18:33 greebo Target Version => 1.8.0
12.10.2012 18:58 greebo Note Added: 0004911
12.10.2012 18:58 greebo Status assigned => resolved
12.10.2012 18:58 greebo Fixed in Version => 1.8.0
12.10.2012 18:58 greebo Resolution open => fixed
12.10.2012 22:39 STiFU Note Added: 0004913
13.10.2012 07:00 greebo Note Added: 0004914
13.10.2012 09:14 STiFU Note Added: 0004915
13.10.2012 09:36 STiFU Note Edited: 0004915 View Revisions
13.10.2012 09:50 STiFU Note Added: 0004917
13.10.2012 10:09 STiFU Note Edited: 0004917 View Revisions
27.08.2013 14:32 greebo Status resolved => closed