View Issue Details

IDProjectCategoryView StatusLast Update
0003258The Dark ModCodingpublic04.05.2013 01:05
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003258: Stealth score doesn't include arrow alerts?
DescriptionIn ProfessorPaul's LP of In the North, he shoots several broadheads, which sends nearby guards into agitated searching. Yet at the end his stealth score was 1...that alert wasn't tracked.

http://forums.thedarkmod.com/topic/14254-stealth-score/page__pid__299075#entry299075
TagsNo tags attached.

Activities

Springheel

Springheel

02.11.2012 21:25

administrator   ~0004930

Perhaps something bigger is broken?

"Isn't it a bit strange that the stealth score was only 6? A guard saw me. I got hit twice with a sword and then I managed to escape and the whole manor was alerted and everyone took wielded arms?"
grayman

grayman

02.05.2013 04:23

administrator   ~0005353

I fixed the problem of the stealth score ignoring broadheads.

I tried a few other arrows. A rope arrow impact that doesn't leave a rope (the arrow breaks) acts just like a broken broadhead, and that adds to the stealth score, so that seems correct.

But I have a question about the noisemaker. Currently it does not affect the stealth score, even though it alerts the AI and makes them search. This seems reasonable, because the player can use this arrow to divert attention (a good thing), so it doesn't seem fair to bump the stealth score when it's used.

Comments on that?
Springheel

Springheel

03.05.2013 21:57

administrator   ~0005355

Huh. Not sure how I feel about that one. Might be good to get some public feedback.
grayman

grayman

04.05.2013 01:03

administrator   ~0005361

The actor responsible for firing the arrow needed to be recorded in the projectile result, which could then tell the AI alert code, which could then tell mission statistics.

Rev. 5748:

AI.cpp
AI.h
ProjectileResult.cpp
AI_events.cpp

Tested with startmap.map.
grayman

grayman

04.05.2013 01:05

administrator   ~0005362

Since my noisemaker question is now on the forums, I'm resolving this one, so my code changes don't sit around too long.

If the forum question results in noisemakers needing to be counted in the stealth score, I'll create a separate issue just for that.

Issue History

Date Modified Username Field Change
28.10.2012 12:46 Springheel New Issue
02.11.2012 21:25 Springheel Note Added: 0004930
02.05.2013 04:07 grayman Assigned To => grayman
02.05.2013 04:07 grayman Status new => assigned
02.05.2013 04:23 grayman Note Added: 0005353
02.05.2013 04:23 grayman Status assigned => feedback
03.05.2013 21:57 Springheel Note Added: 0005355
03.05.2013 21:57 Springheel Status feedback => assigned
04.05.2013 01:03 grayman Note Added: 0005361
04.05.2013 01:03 grayman Status assigned => resolved
04.05.2013 01:03 grayman Resolution open => fixed
04.05.2013 01:03 grayman Fixed in Version => TDM 2.00
04.05.2013 01:03 grayman Target Version => TDM 2.00
04.05.2013 01:05 grayman Note Added: 0005362