View Issue Details

IDProjectCategoryView StatusLast Update
0003264The Dark ModCodingpublic26.11.2012 18:31
ReporterConstantine Assigned Totels  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003264: Noshadows_lod_x spawnarg actually affects (x-1) LOD
DescriptionThe noshadows_lod_1 spawnarg actually controls LOD 0 shadows, noshadows_lod_2 works at LOD 1, etc.

Here is a demo using all the LODs in the attached file. The shadows are disabled at LOD 3 and 4 in def, but actually they disappear at LOD 2 and 3.

I also found that there is no way to disable shadows at last LOD (independently of the number of LODs), because the corresponding noshadows_lod_x affects the previous (x-1) LOD, and noshadows_lod_x+1 doesn't work if the next LOD (x+1) isn't set.
Steps To ReproducePut the lodtest.pk4 file in the darkmod folder ant type "map lodtest" in the console.
TagsNo tags attached.

Activities

Constantine

Constantine

26.11.2012 18:23

updater  

lodtest.pk4 (69,975 bytes)
tels

tels

26.11.2012 18:31

reporter   ~0004946

Fixed with revision #5656, which is just this:

- renderEntity.noShadow = (m_LOD->noshadowsLOD & (1 << (m_LODLevel + 1))) > 0 ? 1 : 0;
+ renderEntity.noShadow = (m_LOD->noshadowsLOD & (1 << m_LODLevel)) > 0 ? 1 : 0;

Thank you for the report!

Issue History

Date Modified Username Field Change
26.11.2012 18:23 Constantine New Issue
26.11.2012 18:23 Constantine File Added: lodtest.pk4
26.11.2012 18:29 tels Assigned To => tels
26.11.2012 18:29 tels Status new => assigned
26.11.2012 18:30 tels OS Windows 7 =>
26.11.2012 18:30 tels OS Version 64 bit =>
26.11.2012 18:30 tels Platform AMD Athlon 64 X2 3800+ 4GB RAM =>
26.11.2012 18:30 tels Target Version => TDM 2.00
26.11.2012 18:31 tels Note Added: 0004946
26.11.2012 18:31 tels Status assigned => resolved
26.11.2012 18:31 tels Fixed in Version => TDM 2.00
26.11.2012 18:31 tels Resolution open => fixed