View Issue Details

IDProjectCategoryView StatusLast Update
0003294The Dark ModTweakingpublic25.01.2013 13:18
Reportergnartsch Assigned Totels  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003294: Integrated Mission Downloader has inconsistent mission handling (for some missions)
DescriptionI downloaded the latest mission (TheBuilderRoads by Obsttorte) via TDM itself.
The mission gets downloaded and can be installed and played. However it shows up on the list of 'Availlable downloads' all over again, right after the download completed successfully.

I have all TDM missions downloaded and the code which handles the mission info seems to have problems with 3 of them. However, TheBuilderRoad is the only one which keeps popping up on the 'Availlable Download' list.

Nevertheless, the handling of the mission info seems to be wrong and the 'missions.tdminfo' file contains 2 entries for some missions.

The Builder Roads - by Obsttorte
Deceptive Shadows - by Shadowhide
Vengeance for a Thief - by Sir Taffsalot
Steps To ReproduceOpen TDM and let it seek for new missions.
Select 'The Builder Road' and download it.
Right after the download is complete, TDM adds it also back to the 'Availlable downloads'
Additional Informationtdm_missioninfo broads.pk4
{
    "downloaded_version" "1"
}

tdm_missioninfo broads_pk4
{
    "last_play_date" "2013-01-20"
    "mission_completed_1" "1"
    "mission_loot_collected_1" "1550"
}

tdm_missioninfo DeceptiveShadows
{
    "downloaded_version" "1"
}

tdm_missioninfo VFAT1
{
    "downloaded_version" "1"
}

tdm_missioninfo deceptiveshadows
{
}

tdm_missioninfo vfat1
{
}
TagsNo tags attached.

Activities

gnartsch

gnartsch

20.01.2013 15:37

reporter  

missions.tdminfo (3,887 bytes)
tels

tels

25.01.2013 13:18

reporter   ~0005025

The reason for the duplicated entries and the "still downloadable" was that the mod name field on the server should contain only:

* lowercase (NOT "DeceptiveShadows" or "VFAT1")
* no special characters (so no "mission+something")
* no extension (so it is "broads", not "broads.pk4")

The code now corrects all these mistakes after downloading the mission info, so even when the fields are wrong on the server, it will still work in the menu.

People with this issue need probably to delete their fms/missions.tdminfo (or edit it and remove the double entries) to get the missions to work correctly.

Issue History

Date Modified Username Field Change
20.01.2013 15:17 gnartsch New Issue
20.01.2013 15:37 gnartsch File Added: missions.tdminfo
25.01.2013 13:15 tels Assigned To => tels
25.01.2013 13:15 tels Status new => assigned
25.01.2013 13:16 tels Severity normal => minor
25.01.2013 13:16 tels Reproducibility always => sometimes
25.01.2013 13:16 tels OS Windows =>
25.01.2013 13:16 tels OS Version 7 =>
25.01.2013 13:16 tels Platform Intel Quadcore =>
25.01.2013 13:16 tels Target Version => TDM 2.00
25.01.2013 13:16 tels Additional Information Updated View Revisions
25.01.2013 13:18 tels Note Added: 0005025
25.01.2013 13:18 tels Status assigned => resolved
25.01.2013 13:18 tels Fixed in Version => TDM 2.00
25.01.2013 13:18 tels Resolution open => fixed