View Issue Details

IDProjectCategoryView StatusLast Update
0003311The Dark ModDesign/Codingpublic15.05.2013 15:26
ReporterObsttorte Assigned To 
Status acknowledgedResolutionopen 
Product VersionTDM 1.08 
Summary0003311: Dmap does not delete nor overwrite .cm files
DescriptionThe original report was:

"It appears that the trigger_entityname entity does not work anymore after renaming it."

This is caused by dmap not properly overwriting .cm or .proc files.
Steps To ReproduceCreate a brush -> create entity -> trigger_entityname. If it is the first one it will be called "trigger_entityname_1". Now just change that name and dmap. It won't work anymore.
Additional InformationThis is very frustrating for mappers as it can cause alls sort of strange bugs - I too, suddenly recognizes a few strange bugs I chased for hours to be likely the reason for this.
TagsNo tags attached.




31.01.2013 20:11

developer   ~0005041

If you rename it back to its original name afterwards it works again.


02.02.2013 12:51

developer   ~0005046

This problem applies to trigger_entityname, trigger_once_entityname, trigger_once and trigger_multiple.


02.02.2013 18:39

administrator   ~0005048

Last edited: 02.02.2013 18:42

View 2 revisions

This isn't a problem. Dmap sometimes doesn't overwrite an existing *.cm file. This is not likely to get fixed, since the workaround is simply to delete the old *.cm file and let dmap make a new one.

The *.cm file created by dmap includes collision model info. The first time you dmapped, it saved the initial entity name in the *.cm file. When you changed the entity name and then re-dmapped, and dmap didn't overwrite *.cm, TDM tried to find the renamed collision model in *.cm, couldn't find it, and ended up doing nothing. It basically stopped recognizing the trigger.

When odd things like this happen, you can try deleting the *.proc, *.cm, and *.aas* files before dmapping to see if that fixes the problem.


This same problem can cause another odd effect: if you change the material on a brush, then re-dmap, the brush might behave like it has the old material on it. (I.e. try firing arrows at a wood wall, change the texture to metal, and try arrows again. Sometimes they'll stick. Fixed by deleting dmap's product files and re-dmapping.)



02.02.2013 21:20

developer   ~0005049

I tested it and you are right. So "not a problem". But I would suggest that sometimes the dmapping method is changed in a way that it deletes the cm, proc and aas files at the beginning to avoid such things.

Issue History

Date Modified Username Field Change
31.01.2013 20:09 Obsttorte New Issue
31.01.2013 20:11 Obsttorte Note Added: 0005041
02.02.2013 12:51 Obsttorte Note Added: 0005046
02.02.2013 18:39 grayman Note Added: 0005048
02.02.2013 18:42 grayman Note Edited: 0005048 View Revisions
02.02.2013 21:20 Obsttorte Note Added: 0005049
03.02.2013 10:02 tels Summary Trigger_entityname does not work if renamed. => Dmap does not delete nor overwrite .cm files
03.02.2013 10:02 tels Description Updated View Revisions
03.02.2013 10:02 tels Additional Information Updated View Revisions
03.02.2013 10:02 tels Assigned To => tels
03.02.2013 10:02 tels Status new => acknowledged
03.02.2013 10:02 tels Severity major => normal
03.02.2013 10:02 tels Reproducibility have not tried => sometimes
15.05.2013 15:26 tels Assigned To tels =>