View Issue Details

IDProjectCategoryView StatusLast Update
0000332DarkRadiantMap Editingpublic30.06.2009 19:56
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.2 
Target Version0.10.0Fixed in Version0.10.0 
Summary0000332: Option to fix origin when resizing lights
DescriptionRaised by Komag: http://modetwo.net/darkmod/index.php?showtopic=6175&st=0&#entry118627

Basically the desired action is that the origin is anchored/doesn't move, when resizing lights. Might be best as a preference, instead of discarding the current method as well.
TagsNo tags attached.

Activities

SneaksieDave

SneaksieDave

03.05.2008 18:50

developer   ~0001192

Last edited: 04.05.2008 15:44

Well that was weird; I almost tracked this again, using almost the same words. Short memory, but consistent I guess.

Anyway, I run into this each and every time I place a light.

5 create light
10 position it (origin is not in correct spot)
20 resize (it's not the correct size); count++
30 If count > 100, end; else, goto 10

I'd personally put this at "highly desirable", if it's queuing up.

Edit: in fact (heh, I just hit it again) I can't really think of a reason this shouldn't be default/only behavior. When does a mapper want a light's origin moving out of their control, just because they resize? In fact, if they want the light/origin moved, they would simply grab it and move it. Resizing is a completely separate desire, in all cases I can think of.

Komag

Komag

09.05.2008 05:41

reporter   ~0001199

I agree, it should be default. But the other option might be best still available, for such things as parallel or ambient lighting, which is over an area and not necessarily centerend on anything (such as a real lamp/torch)

Issue History

Date Modified Username Field Change
09.07.2007 17:17 SneaksieDave New Issue
09.07.2007 17:20 greebo Status new => acknowledged
03.05.2008 18:50 SneaksieDave Note Added: 0001192
04.05.2008 15:44 SneaksieDave Note Edited: 0001192
09.05.2008 05:41 Komag Note Added: 0001199
19.06.2009 14:48 greebo Status acknowledged => assigned
19.06.2009 14:48 greebo Assigned To => greebo
19.06.2009 15:45 greebo Status assigned => resolved
19.06.2009 15:45 greebo Fixed in Version => 0.10.0
19.06.2009 15:45 greebo Resolution open => fixed
19.06.2009 15:45 greebo Projection none => major rework
19.06.2009 15:45 greebo ETA none => < 1 day
19.06.2009 15:45 greebo Build => 4637
19.06.2009 15:45 greebo Target Version => 0.10.0
30.06.2009 19:56 SneaksieDave Status resolved => closed