View Issue Details

IDProjectCategoryView StatusLast Update
0003341The Dark ModAIpublic08.06.2013 20:28
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Fixed in VersionTDM 2.00 
Summary0003341: AI do not do random head-turning when searching?
DescriptionAI often stand and stare in one direction for a long period of time while searching. It frequently looks fake. They should probably be turning their head and looking this way and that, but I think random head-turning is turned off when AI are alert. Check to see if it is, and if it can be enabled.
TagsNo tags attached.

Activities

grayman

grayman

10.03.2013 15:54

administrator   ~0005149

This behavior is controlled by where the spots are that the hiding spot search gives the AI. If a sequence of spots aren't far from each other, the AI will stand still and only look at the spots.

Sometimes the AI will stand still, but turn his head to look at the next spot.

Idle head-turning might interfere with looking at specific spots, so it needs to be tested well.

Also, simple test architecture, which is what we usually create for debugging, might not be sufficient to test this, since the hiding spot search isn't going to find many spots; the list is built up based on interesting lighting differences in the area of the search. Behind boxes, down an adjacent corridor, etc. If the architecture is simple, the lighting is all the same, and there are no func_statics sitting around, the AI is most likely to just stand there.
Springheel

Springheel

11.03.2013 20:51

administrator   ~0005153

Lost my reply to the above; this is generally a problem in dark areas where the player has put out the lights; while a real person is unlikely to stare in one direction for more than 5 to 10 seconds while searching, AI often do two or three times this amount.


Some relevant spawnargs to look at.

"headturn_delay_min" "3"
    "headturn_chance_idle" "0.3"
    "headturn_factor_alerted" "2"
grayman

grayman

04.06.2013 16:39

administrator   ~0005522

Please see if this is still a problem. I randomized the selection of spots from the hiding spot list, so AI are now less likely to stand in one place for long periods.
Springheel

Springheel

08.06.2013 20:28

administrator   ~0005539

Yes, this seems much better now.

Issue History

Date Modified Username Field Change
09.03.2013 22:11 Springheel New Issue
09.03.2013 22:11 Springheel Status new => assigned
09.03.2013 22:11 Springheel Assigned To => Springheel
10.03.2013 15:54 grayman Note Added: 0005149
11.03.2013 20:51 Springheel Note Added: 0005153
04.06.2013 16:39 grayman Note Added: 0005522
08.06.2013 20:28 Springheel Note Added: 0005539
08.06.2013 20:28 Springheel Status assigned => resolved
08.06.2013 20:28 Springheel Fixed in Version => TDM 2.00
08.06.2013 20:28 Springheel Resolution open => fixed