View Issue Details

IDProjectCategoryView StatusLast Update
0000338DarkRadiantMap Editingpublic09.11.2007 19:11
ReporterSneaksieDave Assigned ToSneaksieDave  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.1 
Fixed in Version0.9.4 
Summary0000338: Select Complete Tall and Select Inside not selecting some func_statics
DescriptionOr at least that's what seems to be going on.

Open snow.map, drag a box over the entire sitting area, and use Select Complete Tall. Alternately, surround the room with a box and perform Select Inside. In both cases, the couch, chairs, and a few other func_statics with model assignments are not selected. On the other hand, a newly created func_static brush selects fine. Not sure what's going on here, but something's definitely wrong, and it worked in the past, so I assume relatively recent change is causing this.

Select partial tall (shift-drag) does not seem to be affected.
TagsNo tags attached.

Relationships

related to 0000388 closedgreebo Can't drag func_* origins after they are outside of brush bounds 

Activities

SneaksieDave

SneaksieDave

11.10.2007 15:39

developer   ~0000757

Last edited: 11.10.2007 16:01

I just went to try a prefab request on the boards, and when it wasn't working, I looked a bit closer and realized what was going on - it wasn't selecting the model (in this case a candle). So it's not just func_statics -- apparently it can also include e.g., moveable_base, and who knows what else.

In test/torch, select complete tall over one of the candles near the north side of the map. The candle models are not selected. More strangely, and I haven't figured out what's going on here yet: hide all parts of a candle except the candle model. Now, do select complete tall over that candle model. While the model is not selected, it does display the dimensions info (x-size, y-size, coords). So, maybe it is selecting the origin, or some kind of non-displayed hull, but not the model?

Request that the importance of this be bumped up - I for one use select complete tall exclusively.

Edit: I think I see why it is showing the dimensions info -- select complete tall is still selecting the CM, even though it is hidden! So I guess that's another problem.

Edit 2: I'll track the dimensions issue separately, because it seems like a completely different problem. (0000363)

greebo

greebo

11.10.2007 17:30

administrator   ~0000762

Fixed in SVN. The AABBs were wrongly calculated for models and func_statics due to my recent changes concerning the CurveNURBS editing support.
SneaksieDave

SneaksieDave

11.10.2007 19:12

developer   ~0000764

:)!
greebo

greebo

09.11.2007 14:20

administrator   ~0000849

Last edited: 09.11.2007 14:31

I had to make some changes to the fix I made to resolve this issue. There is a small chance that I broke something again, so please test this once more. Thanks!

New snapshot is on FTP, btw.

SneaksieDave

SneaksieDave

09.11.2007 19:11

developer   ~0000857

Looks good.

Issue History

Date Modified Username Field Change
26.07.2007 15:29 SneaksieDave New Issue
26.07.2007 15:33 SneaksieDave Description Updated
26.07.2007 16:09 greebo Status new => confirmed
26.07.2007 16:09 greebo Status confirmed => acknowledged
11.10.2007 15:39 SneaksieDave Note Added: 0000757
11.10.2007 15:39 SneaksieDave Status acknowledged => feedback
11.10.2007 15:41 SneaksieDave Note Edited: 0000757
11.10.2007 15:46 SneaksieDave Note Edited: 0000757
11.10.2007 16:01 SneaksieDave Note Edited: 0000757
11.10.2007 16:17 greebo Status feedback => assigned
11.10.2007 16:17 greebo Assigned To => greebo
11.10.2007 17:30 greebo Status assigned => resolved
11.10.2007 17:30 greebo Fixed in Version => latest SVN
11.10.2007 17:30 greebo Resolution open => fixed
11.10.2007 17:30 greebo Note Added: 0000762
11.10.2007 19:12 SneaksieDave Status resolved => closed
11.10.2007 19:12 SneaksieDave Note Added: 0000764
09.11.2007 14:20 greebo Assigned To greebo => SneaksieDave
09.11.2007 14:20 greebo Note Added: 0000849
09.11.2007 14:20 greebo Status closed => feedback
09.11.2007 14:20 greebo Resolution fixed => reopened
09.11.2007 14:20 greebo Relationship added related to 0000388
09.11.2007 14:31 greebo Note Edited: 0000849
09.11.2007 19:11 SneaksieDave Note Added: 0000857
09.11.2007 19:11 SneaksieDave Status feedback => closed
09.11.2007 19:11 SneaksieDave Resolution reopened => fixed
09.11.2007 19:11 SneaksieDave Fixed in Version 0.9.3 => 0.9.4