View Issue Details

IDProjectCategoryView StatusLast Update
0003381The Dark ModGUIpublic21.04.2013 03:18
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003381: Briefing videos are broken
DescriptionThe first half of mainmenu_briefing_video.gui handles the case of one or more briefing videos for a standalone mission.

The second half handles one or more briefing videos for a campaign.

The standalone section does not work for two or more videos. From video 2 on, the video doesn't start at its beginning. It starts somewhere inside the video.

The campaign section plays the videos correctly, but requires a second restart to do so.
TagsNo tags attached.

Activities

grayman

grayman

21.04.2013 03:18

administrator   ~0005303

Single-mission briefing videos …

In mainmenu_briefing_video.gui, the following syntax:

else if ( MM_BRIEFING_VIDEO_LENGTH_2 > 0 )
{
    resetCinematics ; // Reset Video to start
    set "Video::background" MM_BRIEFING_VIDEO_MATERIAL_2
}

doesn’t work. The line missing an ending semicolon doesn’t allow any command on the next line to execute, and the reset request gets applied to the current ‘background’, not to the one about to be set.

Correct syntax:

else if ( MM_BRIEFING_VIDEO_LENGTH_2 > 0 )
{
    set "Video::background" MM_BRIEFING_VIDEO_MATERIAL_2;
    resetCinematics ; // Reset Video to start
}

This syntax allows the reset request to run, and to be applied to the new ‘background’.

Also, further down, MM_BRIEFING_VIDEO_MATERIAL_10 was being requested instead of MM_BRIEFING_VIDEO_MATERIAL_9.

Campaign briefing videos …

The video information is only read in the first time the main menu screen is displayed. If the current mission (campaign) is uninstalled, then reinstalled, the video information isn’t read again, but is cleared during the restarts that take place with installing and uninstalling. This caused the videos not to play when the mission was finally started, because the video information was gone.

To ensure that the video information is available, I added a request at the start of the campaign video briefing initialization to load the video information. This guarantees that it’s available when needed. This allows the videos to play.

Rev. 13422:

mainmenu_briefing_video.gui

Tested with Sotha’s video_test.pk4 and video_test_cam.pk4.

Issue History

Date Modified Username Field Change
21.04.2013 00:49 grayman New Issue
21.04.2013 00:49 grayman Status new => assigned
21.04.2013 00:49 grayman Assigned To => grayman
21.04.2013 03:18 grayman Note Added: 0005303
21.04.2013 03:18 grayman Status assigned => resolved
21.04.2013 03:18 grayman Resolution open => fixed
21.04.2013 03:18 grayman Fixed in Version => TDM 2.00