View Issue Details

IDProjectCategoryView StatusLast Update
0003389The Dark ModAIpublic29.04.2013 01:56
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003389: Inaccurate AI positioning on elevators
DescriptionDiscovered that the elevator code is querying the "translation" spawnarg on elevator buttons to determine where an AI should stand when it's time to push the button.

This has been around forever, but the problem is there's no "translation" spawnarg on elevator buttons. The code should be using the "translate" spawnarg. Apparently the default value for the nonexistent "translation" was close enough to let AI use elevators.
TagsNo tags attached.

Activities

grayman

grayman

29.04.2013 01:56

administrator   ~0005336

Ask buttons for “translate” spawnarg instead of the “translation” spawnarg.

Also, use the floor level when giving AI positions to move to.

Rev. 5742:

HandleElevatorTask.cpp

Tested with elevator2.map.

Issue History

Date Modified Username Field Change
29.04.2013 00:27 grayman New Issue
29.04.2013 00:27 grayman Status new => assigned
29.04.2013 00:27 grayman Assigned To => grayman
29.04.2013 01:56 grayman Note Added: 0005336
29.04.2013 01:56 grayman Status assigned => resolved
29.04.2013 01:56 grayman Resolution open => fixed
29.04.2013 01:56 grayman Fixed in Version => TDM 2.00