View Issue Details

IDProjectCategoryView StatusLast Update
0003423The Dark ModAIpublic03.06.2013 00:48
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003423: Idle barks during searches
DescriptionI've been feeling like the AI aren't reacting as they should, so while playing Sons of Baltona, I flashed my lamp on for half a second. An AI at the other end of the room said, "That certainly seemed like something," and came over without his sword drawn, looking around. Half a second later he gave an idle bark, "Time for a quick trip the kitchen after this," before finally finishing his search.

While it was somewhat fitting in this case, we probably don't want AI making idle barks during any level of alert.
TagsNo tags attached.

Activities

grayman

grayman

22.05.2013 22:38

administrator   ~0005494

Here are the idle barks per state:

Idle - "snd_drunk" if drunk, "snd_relaxed" if not
Alert Idle - "snd_alert_idle"
Observant - same as Idle or Alert Idle
Suspicious - same as Idle or Alert Idle
Agitated Searching - "snd_state4SeenEvidence" if evidence was seen, "snd_state4SeenNoEvidence" if not
Combat - none

I didn't find any snd_state2* or snd_state3* barks, so I guess the idle barks were meant to be used in Observant and Suspicious.

Our choices are:

1 - No repeated barks in state2 and state3
2 - Define state2 and state3 bark sets, perhaps from selections from state1 and state4
Springheel

Springheel

23.05.2013 00:41

administrator   ~0005497

Last edited: 23.05.2013 00:41

View 2 revisions

Traditionally # 1 has been true; barks are only made only when entering and leaving that state.

grayman

grayman

02.06.2013 03:21

administrator   ~0005505

After committing the changes for 0003424, I took a look at this one.

In a dark unlit room, ambient only, I flashed the lantern and a guard at the other end of the room got interested, and went right up to Agitated Searching.

He ran down to my end of the room and started searching. He never found me, stopped searching, muttered something about not finding anything, and went back to his start point.

I did this a few times with the same results.

I then tried Baltona, and one of the guards got up into Searching State, and came running over to poke around. He couldn't find me, uttered a rampdown bark along the lines of "Glad it was nothing", and went back to his post.

I did that a couple times, and never heard any idle barks.

So, with rev 13490, I'm unable to reproduce this.
grayman

grayman

02.06.2013 14:43

administrator   ~0005512

Aha! Saw this happen when a guard was in Searching State. He was walking toward me, sword not yet drawn, at alert level 10 or 11, and he said, "Ah. So that's what I was trying to remember."
grayman

grayman

03.06.2013 00:48

administrator   ~0005515

Clear comm tasks (repeated barking) when the Searching State is initialized and the alert level is rising.

Rev. 5802:

SearchingState.cpp

Issue History

Date Modified Username Field Change
20.05.2013 00:48 Springheel New Issue
20.05.2013 00:48 Springheel Summary No idle barks during searches => Idle barks during searches
20.05.2013 10:30 grayman Assigned To => grayman
20.05.2013 10:30 grayman Status new => assigned
22.05.2013 22:38 grayman Note Added: 0005494
23.05.2013 00:41 Springheel Note Added: 0005497
23.05.2013 00:41 Springheel Note Edited: 0005497 View Revisions
02.06.2013 03:21 grayman Note Added: 0005505
02.06.2013 03:34 grayman Status assigned => feedback
02.06.2013 14:43 grayman Note Added: 0005512
03.06.2013 00:25 grayman Status feedback => assigned
03.06.2013 00:48 grayman Note Added: 0005515
03.06.2013 00:48 grayman Status assigned => resolved
03.06.2013 00:48 grayman Resolution open => fixed
03.06.2013 00:48 grayman Fixed in Version => TDM 2.00