View Issue Details

IDProjectCategoryView StatusLast Update
0000343DarkRadiantGeneralpublic03.12.2008 21:38
ReporterFidcal Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.2 
Target Version0.9.6Fixed in Version0.9.6 
Summary0000343: Some models not selected/shown in some situations when region and select inside used.
DescriptionIn some situations models do not show when Region is used. I'm uploading test_region.map there's a book that if selected then View > Region > Set from selection is used it disappears. There is a window there too but this seems OK in this map but in another map it did the same. Also several such windows disappeared even when region was selected by all means. I think this is fairly easy to reproduce. Once set in a map then it always does it. Yet it does not seem to be just a specific model. Witness the window which gave me trouble in my real map yet here it seems OK. But the book failed in my real map and it fails here too. Here's a link to my posting on DM forums with an image of the windows not being selected. I can put that map up if needed...

http://modetwo.net/darkmod/index.php?showtopic=4581&view=findpost&p=120392

I left the severity category as 'minor' as 'major' seemed too extreme but it is serious when trying to work in an area if some things are not shown - both if you need them but also if you don't notice. Also if moving/cloning a complex group and not being confident everything is included.
TagsNo tags attached.

Relationships

duplicate of 0000242 closedgreebo some models disappear when switching on region 

Activities

08.08.2007 07:49

 

test_region.map (7,149 bytes)
greebo

greebo

08.08.2007 07:52

administrator   ~0000731

Yes, this is a known issue: 0000242. Angua caught this some time ago. This will require some deeper refactoring of the regioning. It should be based on the scene::Instances instead of the scene::Nodes, as all instances of a model share a single node. Hide this node and all models are invisible.
greebo

greebo

18.03.2008 20:14

administrator   ~0001092

This should be resolved in the scenegraph branch. I will set this to resolved when the code is merged into the trunk.

Issue History

Date Modified Username Field Change
08.08.2007 07:49 Fidcal New Issue
08.08.2007 07:49 Fidcal File Added: test_region.map
08.08.2007 07:50 greebo Status new => acknowledged
08.08.2007 07:50 greebo Relationship added duplicate of 0000242
08.08.2007 07:52 greebo Note Added: 0000731
18.03.2008 20:13 greebo Status acknowledged => assigned
18.03.2008 20:13 greebo Assigned To => greebo
18.03.2008 20:14 greebo Note Added: 0001092
19.03.2008 20:40 greebo Status assigned => resolved
19.03.2008 20:40 greebo Fixed in Version => 0.9.6
19.03.2008 20:40 greebo Resolution open => fixed
19.03.2008 20:41 greebo Projection none => redesign
19.03.2008 20:41 greebo Build => 3260
19.03.2008 20:41 greebo Target Version => 0.9.6
03.12.2008 21:38 greebo Status resolved => closed