View Issue Details

IDProjectCategoryView StatusLast Update
0003445The Dark ModAIpublic21.07.2013 14:42
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003445: AI goes into alert_idle because of rats.
DescriptionOk, another exciting bark issue.

I was using a testmap for greetings, and an AI spotted me before I could put notarget on. It went something like this:

Thug to wench: "Did you see something over there?"

Thug stands for a few seconds looking at me. Did not draw his sword.

Ramps down and says, "Probably some bloody rat." Then draws his sword, resumes patrol, and tells the wench, "We got an intruder."

Something is clearly wrong there. If he thinks there's an intruder, he should not be playing that rampdown bark. If he doesn't think there's an intruder, he shouldn't be going into alert_idle state.

If AI have no evidence of an intruder, and they have not reached agitated searching, I don't think they should go into alert_idle state (unless they're doing it because they were warned by another AI).

TagsNo tags attached.

Relationships

duplicate of 0003472 resolvedgrayman AI playing wrong rampdown bark 

Activities

grayman

grayman

11.06.2013 03:45

administrator   ~0005554

You said he spent a few seconds looking at you. I assume you mean he was looking in your direction, but couldn't see you.

Did he stop seeing you because you put notarget on before he could complete the climb up into combat state?

Or did you duck out of sight?

Or were you in shadows the whole time and he heard you but didn't see you?
Springheel

Springheel

12.06.2013 00:57

administrator   ~0005555

Last edited: 12.06.2013 00:58

View 2 revisions

He stopped seeing me because I put notarget on. I guess that's not really a fair case, come to think of it, since notarget can do weird things. I'll have to see if I can recreate it under normal conditions.

grayman

grayman

12.06.2013 01:19

administrator   ~0005556

Yes, going to 'notarget' causes weirdness.

If you can recreate it w/o using notarget, I'm about to check in some code changes that would help in debugging the problem. It'll be a bit more clear as to why he says what he says and why he goes into Alert Idle when he calms down.
grayman

grayman

12.06.2013 02:19

administrator   ~0005557

Code checked in and Windows DLL uploaded to SVN.

You'll want to add these two lines to Darkmod.cfg:

seta tdm_ai_debug_transition_barks "0"
seta tdm_ai_debug_greetings "0"

Set the first cvar to "1" to have debug statements printed to the console. These will show the events that cause an AI to have "seen evidence" and to shift from Idle to Alert Idle. It will also print the barks an AI makes when he transitions to a new alert index (state), so you can see the barks ramping up and down.

This might be useful when reproducing the original problem.
Springheel

Springheel

06.07.2013 02:30

administrator   ~0005643

I think this is actually the same issue as this: 0003472
Springheel

Springheel

21.07.2013 14:42

administrator   ~0005850

This should be fixed with all the recent changes.

Issue History

Date Modified Username Field Change
09.06.2013 23:58 Springheel New Issue
11.06.2013 03:45 grayman Note Added: 0005554
12.06.2013 00:57 Springheel Note Added: 0005555
12.06.2013 00:58 Springheel Note Edited: 0005555 View Revisions
12.06.2013 01:19 grayman Note Added: 0005556
12.06.2013 02:19 grayman Note Added: 0005557
13.06.2013 19:07 Springheel Assigned To => Springheel
13.06.2013 19:07 Springheel Status new => feedback
06.07.2013 02:30 Springheel Note Added: 0005643
06.07.2013 02:30 Springheel Status feedback => assigned
06.07.2013 02:30 Springheel Relationship added duplicate of 0003472
06.07.2013 12:18 Springheel Assigned To Springheel =>
07.07.2013 22:35 grayman Assigned To => grayman
07.07.2013 22:35 grayman Status assigned => feedback
21.07.2013 14:42 Springheel Note Added: 0005850
21.07.2013 14:42 Springheel Status feedback => assigned
21.07.2013 14:42 Springheel Status assigned => resolved
21.07.2013 14:42 Springheel Fixed in Version => TDM 2.00
21.07.2013 14:42 Springheel Resolution open => fixed