View Issue Details

IDProjectCategoryView StatusLast Update
0003466The Dark ModDef / Setuppublic30.06.2013 21:42
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Summary0003466: Remove Persontype: Elite
DescriptionThere really shouldn't be a need for this persontype; only 2 AI types use this. Rank should handle any special behaviour, and it will cause problems for greetings.
TagsNo tags attached.

Activities

Springheel

Springheel

28.06.2013 18:37

administrator   ~0005610

Also, most characters will need specific "to_builder" greetings.
grayman

grayman

29.06.2013 01:03

administrator   ~0005613

When determining the response to a greeting, PERSONTYPE_ELITE, PERSONTYPE_NOBLE, and PERSONTYPE_PRIEST are considered equivalent.

If the responder is one of these, they bark "snd_response_positive".

If not, and the greeter is one of these, the responder barks "snd_response_positive_superior".

So I assume we'll simply remove PERSONTYPE_ELITE from that set.
Springheel

Springheel

29.06.2013 01:11

administrator   ~0005615

Yes. IIRC there's also something that checks rank, which should cover it.
grayman

grayman

29.06.2013 02:45

administrator   ~0005616

PERSONTYPE_ELITE is used if one or both AI have a rank of '0'.

What will ELITE be replaced with?
Springheel

Springheel

29.06.2013 11:46

administrator   ~0005617

Last edited: 29.06.2013 11:47

View 2 revisions

There were only two characters using it, and I've switched them to PROGUARD. The elite citywatch wasn't even using it.

I think the only characters with a rank of 0 are beggars. Which means they would use "snd_response_positive_superior" to anyone other than another beggar (since "snd_response_positive_superior" is used when the greeter's rank is higher than the responder's, IIRC).

Issue History

Date Modified Username Field Change
28.06.2013 18:03 Springheel New Issue
28.06.2013 18:03 Springheel Status new => assigned
28.06.2013 18:03 Springheel Assigned To => Springheel
28.06.2013 18:37 Springheel Note Added: 0005610
29.06.2013 01:03 grayman Note Added: 0005613
29.06.2013 01:11 Springheel Note Added: 0005615
29.06.2013 02:45 grayman Note Added: 0005616
29.06.2013 11:46 Springheel Note Added: 0005617
29.06.2013 11:47 Springheel Note Edited: 0005617 View Revisions
30.06.2013 21:42 Springheel Status assigned => resolved
30.06.2013 21:42 Springheel Resolution open => fixed