View Issue Details

IDProjectCategoryView StatusLast Update
0003468The Dark ModAIpublic06.07.2013 02:20
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.00Fixed in VersionTDM 2.00 
Summary0003468: Zombies kneel while searching
DescriptionZombies use the same animations and search behaviour as other humanoids. I saw a zombie kneel down while searching for me, and it just felt wrong (oddly, I don't recall even seeing a revenant doing that).

Is there an easy way to turn this behaviour off? If not, I could replace the kneeling animation with something else.
TagsNo tags attached.

Activities

Springheel

Springheel

02.07.2013 16:49

administrator   ~0005623

I've added the following line to undead_zombie.def. That will eliminate the immediate problem for now.
grayman

grayman

05.07.2013 18:49

administrator   ~0005638

That's probably a good long-term solution.

The alternative, which requires a code change, is to add a new spawnarg:

"can_kneel" "1" - default
"can_kneel" "0" - don't kneel

And I have seen revenants kneel, so they should get the same treatment as zombies.
Springheel

Springheel

05.07.2013 19:19

administrator   ~0005639

Last edited: 05.07.2013 19:20

View 2 revisions

Does it bother you when revenants kneel? They're supposed to be intelligent, so I could see it making sense for them to do that. It just doesn't work with unintelligent creatures, like zombies, since the animation clearly looks like the creature is carefully examining the ground.

grayman

grayman

05.07.2013 19:20

administrator   ~0005640

If they're intelligent, then it's fine.

Issue History

Date Modified Username Field Change
01.07.2013 01:17 Springheel New Issue
02.07.2013 16:49 Springheel Note Added: 0005623
05.07.2013 18:49 grayman Note Added: 0005638
05.07.2013 19:19 Springheel Note Added: 0005639
05.07.2013 19:20 Springheel Note Edited: 0005639 View Revisions
05.07.2013 19:20 grayman Note Added: 0005640
06.07.2013 02:20 Springheel Status new => resolved
06.07.2013 02:20 Springheel Resolution open => fixed
06.07.2013 02:20 Springheel Assigned To => Springheel
06.07.2013 02:20 Springheel Fixed in Version => TDM 2.00