View Issue Details

IDProjectCategoryView StatusLast Update
0003516The Dark ModCodingpublic17.02.2020 05:03
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 1.08 
Target VersionTDM 2.02Fixed in VersionTDM 2.02 
Summary0003516: AI can be blocked by simple movable
DescriptionHolding a candle or other movable between the player and an AI is an effective way to keep them at bay. AI keep running around trying to find a clear path.

A possible solution would be to have carried objects fall from the player's grasp when they make contact with an AI. So if the player tries to use something to block the AI, it will make contact and fall.

I can't think of any legitimate reasons players might have for holding onto a movable object that makes contact with an AI.
TagsNo tags attached.

Relationships

duplicate of 0000052 resolved Player can keep AI at bay with held objects 
has duplicate 0001893 closed Player can use candles to push AI around 
related to 0005157 resolvedstgatilov Random collisions force player to drop held item 

Activities

grayman

grayman

12.04.2014 18:25

administrator   ~0006520

If a collision occurs, check if an object held by the player has collided with an AI. If so, drop the held object. Accounts for objects that are teams of multiple objects (i.e. candle entity bound to candle holder entity).

Rev. 5953:

State.cpp
AI.cpp
Physics_Rigidbody.cpp
Entity.cpp
Entity.h

Issue History

Date Modified Username Field Change
11.08.2013 00:28 Springheel New Issue
04.09.2013 13:33 grayman Assigned To => grayman
04.09.2013 13:33 grayman Status new => assigned
23.11.2013 16:28 grayman Target Version TDM 2.01 => TDM 2.02
04.04.2014 02:06 grayman Assigned To grayman =>
04.04.2014 02:06 grayman Assigned To => grayman
04.04.2014 02:06 grayman Status assigned => acknowledged
04.04.2014 02:07 grayman Assigned To grayman =>
12.04.2014 00:15 grayman Assigned To => grayman
12.04.2014 00:15 grayman Status acknowledged => assigned
12.04.2014 18:25 grayman Note Added: 0006520
12.04.2014 18:25 grayman Status assigned => resolved
12.04.2014 18:25 grayman Resolution open => fixed
12.04.2014 18:25 grayman Fixed in Version => TDM 2.02
23.05.2014 21:32 grayman Relationship added duplicate of 0000052
10.10.2017 03:39 nbohr1more Relationship added has duplicate 0001893
17.02.2020 05:03 stgatilov Relationship added related to 0005157