View Issue Details

IDProjectCategoryView StatusLast Update
0003555The Dark ModCodingpublic11.07.2018 11:15
ReporterObstler Assigned ToObstler  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0003555: TDM crashes if one FM contains a darkmod.txt file with invalid order.
DescriptionBy default, the order in the darkmod.txt is Title/Description/Author. However, one would suspect the order to be irrevelant. But if you have a different order, the game crashes as soon as you hit the New Mission button in the main menu.
Steps To ReproduceUnpack any FM, change the order in the darkmod.txt file and pack it again. Then start TDM and hit New Mission.
Additional InformationI did not had any FM's installed as I was encountering this. Didn't test whether this plays a role, though.
TagsNo tags attached.

Activities

grayman

grayman

14.09.2013 18:42

administrator   ~0006179

CModInfo::LoadMetaData() is where darkmod.txt is read.

The code expects the fields to be in this order:

Title
Description
Author
Required TDM Version

It will need to change to accept the fields in any order.

Workaround is for authors to put the fields in the expected order.
grayman

grayman

10.04.2016 18:02

administrator   ~0008076

Since the wiki page for releasing your mission describes the contents of the darkmod.txt file in this order:

Title: The Outpost
Description: Break into a builder outpost to retrieve a gold ingot.
Author: angua & greebo
Version: 1
Required TDM Version: 1.01

I see no reason to change the code to accept _any_ order.

Mission authors should just follow the order given on the wiki page.
grayman

grayman

10.04.2016 18:05

administrator   ~0008077

I want to close this issue with a "won't be fixed" resolution.
Obstler

Obstler

11.04.2016 06:44

developer   ~0008081

You are assuming that everyone is looking at that wiki page. Additionally, even if one does, he may not come to the conclusion, that using a different order would cause an issue (at least I didn't). And if the game is crashing than, the respective FM author will have a happy time searching for the reason ;)

So I think we should not leave it like that. Either the game should accept any order or the game should tell the FM author what he or she did wrong. A plain crash is definetely not good.
Obstler

Obstler

11.07.2018 11:14

developer   ~0010668

Fixed with revision #7563.

In addition to the above mentioned issue, leaving out certain fields could cause display errors.

Issue History

Date Modified Username Field Change
14.09.2013 17:13 Obstler New Issue
14.09.2013 18:42 grayman Note Added: 0006179
10.04.2016 15:42 Obstler Assigned To => Obstler
10.04.2016 15:42 Obstler Status new => assigned
10.04.2016 18:02 grayman Note Added: 0008076
10.04.2016 18:05 grayman Note Added: 0008077
11.04.2016 06:44 Obstler Note Added: 0008081
11.07.2018 11:14 Obstler Note Added: 0010668
11.07.2018 11:15 Obstler Status assigned => resolved
11.07.2018 11:15 Obstler Resolution open => fixed
11.07.2018 11:15 Obstler Fixed in Version => TDM 2.07
11.07.2018 11:15 Obstler Target Version => TDM 2.07