View Issue Details

IDProjectCategoryView StatusLast Update
0003564The Dark ModGraphicspublic24.11.2017 16:43
Reportergrayman Assigned To 
PrioritynormalSeveritynormalReproducibilityalways
Status newResolutionopen 
Product VersionTDM 2.00 
Summary0003564: Brief moment of clarity while sinking into murky swimmable water
DescriptionIf the player is on top of murky swimmable water and slowly descends into it, there's a transition from a clear above-water view to a murky underwater view. The murky overlay is applied too late, allowing a brief moment as the water level rises on the screen, uncovering a clear view of what's in the water. As the water level continues to rise, it reaches the point where the murky overlay is applied, snapping the underwater view from clear to murky.

The underwater murky gui needs to be applied earlier.
TagsNo tags attached.

Activities

grayman

grayman

06.07.2015 02:11

administrator   ~0007616

Separate the drawing of the underwater gui texture from the other underwater effects.

Apply the underwater gui texture when the eye gets close enough to the water surface to experience the clipping of the near Z plane.

Account for water that moves up and down (Training Mission).

Change the underwater guis so they accept a broadcast ‘y’ value for where to start painting the background overlay texture.

Rev. 6513:

Player.cpp

Rev. 14334:

All the underwater gui files.
grayman

grayman

07.07.2015 01:10

administrator   ~0007617

Must also handle the case of leaning left and right. The underwater overlay remains parallel to the screen bottom, but the clipped water surface doesn't.
grayman

grayman

31.07.2015 21:23

administrator   ~0007682

Last edited: 31.07.2015 21:25

View 3 revisions

I'm reverting the changes I made for this. While the non-leaning solution was reasonably acceptable, I've been unable to complete a reasonably acceptable solution when the player is leaning. Came very close, but the code began to be filled with fudge factors due to not being able to get a precise solution based on the available math. (Another way to read this is that I simply got tired of working on it after a couple weeks of effort, and getting nowhere.)

While I believe the true solution is to have the renderer ignore the near plane cutoff and paint the water surface to the bottom of the screen when the player's eyes are slightly out of the water, this appears to be an untenable solution, and since I'm not familiar with the renderer, I won't be trying anything in that area myself.

I've saved a copy of my work if anyone wants to revisit this in the future.

grayman

grayman

16.09.2017 18:38

administrator   ~0009263

Maybe I'll get back to this someday. Not for 2.06.

Issue History

Date Modified Username Field Change
01.10.2013 16:34 grayman New Issue
06.07.2015 02:11 grayman Note Added: 0007616
06.07.2015 02:11 grayman Assigned To => grayman
06.07.2015 02:11 grayman Status new => resolved
06.07.2015 02:11 grayman Resolution open => fixed
06.07.2015 02:11 grayman Fixed in Version => TDM 2.04
06.07.2015 02:11 grayman Target Version => TDM 2.04
07.07.2015 01:10 grayman Note Added: 0007617
07.07.2015 01:10 grayman Status resolved => assigned
31.07.2015 21:23 grayman Note Added: 0007682
31.07.2015 21:23 grayman Assigned To grayman =>
31.07.2015 21:23 grayman Status assigned => new
31.07.2015 21:23 grayman Resolution fixed => open
31.07.2015 21:23 grayman Fixed in Version TDM 2.04 =>
31.07.2015 21:23 grayman Target Version TDM 2.04 =>
31.07.2015 21:24 grayman Note Edited: 0007682 View Revisions
31.07.2015 21:25 grayman Note Edited: 0007682 View Revisions
01.12.2016 08:01 grayman Assigned To => grayman
01.12.2016 08:01 grayman Status new => assigned
01.12.2016 08:02 grayman Target Version => TDM 2.06
16.09.2017 18:38 grayman Note Added: 0009263
16.09.2017 18:38 grayman Target Version TDM 2.06 =>
24.11.2017 16:29 grayman Assigned To grayman =>
24.11.2017 16:43 grayman Status assigned => new