View Issue Details

IDProjectCategoryView StatusLast Update
0003600The Dark ModAIpublic22.12.2018 09:54
ReporterSpringheel Assigned To 
PrioritynormalSeveritynormalReproducibilityhave not tried
Status feedbackResolutionreopened 
Product VersionTDM 2.00 
Fixed in VersionTDM 2.06 
Summary0003600: Revenants being killed by swords too easily
DescriptionIn his latest LP, Fen was able to kill revenants with 2 or 3 sword hits if he started with a sneak attack. In one instance he was able to hit and kill the revenant before it was able to draw its sword. That's easier than using water arrows, and really shouldn't be possible. Double check the damage values.
TagsNo tags attached.

Activities

Springheel

Springheel

13.11.2013 20:12

administrator   ~0006232

Not sure how it's happening. Revenants have 150 HP, and are made of "undeadbone", which supposedly applies a damage modifier of 0.1. Even with a successful sneak attack, it should take way more than 2 hits.
Springheel

Springheel

23.11.2013 17:00

administrator   ~0006269

Testing with some zombies, I noticed something unusual. Some sword hits are only doing about 3-5 hp of damage, which is what I would expect with the .1 damage modifier for undead flesh. However, every 3rd hit on average, I do 40-50 points of damage. It's as if the modifier isn't applied consistently. I would expect the same issue is happening here.
Springheel

Springheel

28.11.2013 14:49

administrator   ~0006288

Last edited: 28.11.2013 14:53

View 3 revisions

I recall ages ago talking to Ishtvan about an issue where AI guards were able to kill zombies more easily than they should, and he said something about the code occasionally not detecting the material the sword is hitting. I thought that only affected AI but perhaps it affects the player too; it does seem to be exactly what I'm observing. This is not something that can be fixed for 2.01. I have boosted the revenant HP by an extra 30 in the meantime, which at least adds one more sword-hit.

Springheel

Springheel

13.09.2014 12:21

administrator   ~0006987

Since this can only be fixed in the code, I'm going to unassign it from me.

user81

28.03.2018 09:45

  ~0010207

@Grayman, is this something you can fix..?
grayman

grayman

28.03.2018 12:54

administrator   ~0010267

Prolly not.

I'm cutting back my software contributions after 2.06 is released.

user81

28.03.2018 13:14

  ~0010276

understood

user81

28.03.2018 15:18

  ~0010281

Re-reading Springs first note I remember testing undead in Full moon fever and diect or sneak took a while to kill either, closing tracker.
Springheel

Springheel

29.03.2018 23:56

administrator   ~0010328

How did you establish that this failure to detect the proper material wasn't happening anymore?

user81

30.03.2018 08:09

  ~0010331

Will double check.

Issue History

Date Modified Username Field Change
09.11.2013 13:18 Springheel New Issue
09.11.2013 13:18 Springheel Status new => assigned
09.11.2013 13:18 Springheel Assigned To => Springheel
13.11.2013 20:12 Springheel Note Added: 0006232
23.11.2013 17:00 Springheel Note Added: 0006269
28.11.2013 14:49 Springheel Note Added: 0006288
28.11.2013 14:53 Springheel Note Edited: 0006288 View Revisions
28.11.2013 14:53 Springheel Note Edited: 0006288 View Revisions
28.11.2013 14:54 Springheel Target Version TDM 2.01 => TDM 2.02
23.03.2014 22:40 Springheel Target Version TDM 2.02 =>
13.09.2014 12:21 Springheel Note Added: 0006987
13.09.2014 12:21 Springheel Assigned To Springheel =>
03.01.2015 16:11 grayman Status assigned => new
28.03.2018 09:45 user81 Note Added: 0010207
28.03.2018 12:54 grayman Note Added: 0010267
28.03.2018 13:14 user81 Note Added: 0010276
28.03.2018 15:18 user81 Note Added: 0010281
28.03.2018 15:18 user81 Status new => closed
28.03.2018 15:18 user81 Assigned To => user81
28.03.2018 15:18 user81 Resolution open => fixed
28.03.2018 15:18 user81 Fixed in Version => TDM 2.06
29.03.2018 23:56 Springheel Note Added: 0010328
30.03.2018 08:09 user81 Note Added: 0010331
30.03.2018 08:09 user81 Status closed => feedback
30.03.2018 08:09 user81 Resolution fixed => reopened
22.12.2018 09:54 user81 Assigned To user81 =>