View Issue Details

IDProjectCategoryView StatusLast Update
0003631The Dark ModAIpublic23.05.2014 23:21
ReporterAluminumHaste Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionTDM 2.01 
Target VersionTDM 2.02Fixed in VersionTDM 2.02 
Summary0003631: Can't drag AI bodies via Head
DescriptionFrobbing the head doesn't work, you can frob the head joint but then you can't move the body with it. Frobbing any other part of the body (torso, leg, foot, arm etc.) allows you to move the bodies.
It's actually kind of hard to select the head instead of the torso so I've included a savegame. When you load it up, just frob the body on the ground don't look around etc.

Here's the savegame: https://drive.google...dit?usp=sharing
Mission download:

Quote
WS2 is ready for beta testing.

You will need to update your 2.00 darkmod folder to 2.01 to participate in this beta. You'll find instructions below.

You can pick up the PK4 here. Place it in darkmod/fms/ws2_homeagain/.

Then extract the savegame to the ws2_homeagain/savegames folder.
Steps To ReproduceKnock out or kill an AI, then try dragging them by their head. I can frob the head, but then the body doesn't move.
Additional InformationThis happened with 2 different AI, one was a builder guard, the other was a woman guard.
TagsNo tags attached.

Activities

grayman

grayman

02.01.2014 03:47

administrator   ~0006342

Did it fail in 2.00?

Since a workaround exists (frob the body), I don't see this as a compelling problem to fix in 2.01 if the problem existed in 2.00.

If something we did in 2.01 caused this bad behavior, then it should get fixed in 2.01.
grayman

grayman

17.04.2014 17:28

administrator   ~0006524

Is this still a problem?

The savegame isn't available.

I copied the female guard from Home Again to a new map, KO'ed her, and couldn't get her head to highlight by itself. The head and body always highlighted together, so frobbing her never failed.

I also have a Citywatch guard in that test map, and the same thing happened with him.

This is using SVN. I don't know of any frobbing changes we've made since 2.01, though.

Can I mark this as not being able to reproduce?
AluminumHaste

AluminumHaste

17.04.2014 18:09

developer   ~0006526

I'll try it tonight and see if I can reproduce.
AluminumHaste

AluminumHaste

18.04.2014 15:16

developer   ~0006530

I just tried this in Thief's Den and it is different now, when highlighting AI both head and body highlight together.

However, now I can't even select the head anymore. When I try, it always grabs the chest instead, which makes a lot of noise as the body flails around a lot.
If this is now normal, go ahead and close this off.
grayman

grayman

18.04.2014 16:11

administrator   ~0006531

I don't know if it's normal or not.

Are we supposed to be able to grab just the head?
AluminumHaste

AluminumHaste

21.04.2014 14:13

developer   ~0006542

I would like to, I often push unconscious AI under tables and shelves, and sometimes I have to put them feet first. Not being able to frob the head means sometimes it's impossible to get the AI all the way under the table/shelve etc.
grayman

grayman

21.04.2014 14:16

administrator   ~0006543

Let me rephrase that...

Were we ever able to grab just the head and it's something that no longer works?
AluminumHaste

AluminumHaste

21.04.2014 15:15

developer   ~0006544

Honestly I can't remember, I think so. I'll load up 1.08 and check.
AluminumHaste

AluminumHaste

21.04.2014 15:24

developer   ~0006545

Yes you could: http://imageshack.com/a/img841/2541/km96.jpg
grayman

grayman

23.05.2014 03:28

administrator   ~0006619

Last edited: 23.05.2014 03:29

View 2 revisions

When the head is frobbed, the code finds that it's attached to the body, and tells the grabber to grab the body, not the head. The 1.08 code is identical, so there have been no changes since 1.08.

Tomorrow I'll look at different heads to see if they behave differently depending on their attributes.

I'll also look at why arms and legs can be grabbed. Why don't they transfer the grabber to the body like the head does?

grayman

grayman

23.05.2014 23:14

administrator   ~0006620

Last edited: 23.05.2014 23:21

View 2 revisions

Had to recognize the circumstances of the rare case when it appeared that you were grabbing the head, and force those circumstances every time you frob the head. This tricks the grabber into thinking you’re grabbing the torso somewhere near the neck, at an invalid joint. For some reason, the grabber thinks that’s okay, and it looks like you’re grabbing the head.

Fixed a problem where the joint number of a previous grab was left over and being used when you grabbed a different joint. Just needed some initialization.

Added code to highlight the head when grabbing a body (either by a body part or by the head).

Rev. 6014:

Entity.cpp
Grabber.cpp

Issue History

Date Modified Username Field Change
26.12.2013 22:27 AluminumHaste New Issue
02.01.2014 03:47 grayman Note Added: 0006342
12.01.2014 23:14 Springheel Target Version TDM 2.01 => TDM 2.02
17.04.2014 17:28 grayman Note Added: 0006524
17.04.2014 18:09 AluminumHaste Note Added: 0006526
18.04.2014 15:16 AluminumHaste Note Added: 0006530
18.04.2014 16:11 grayman Note Added: 0006531
21.04.2014 14:13 AluminumHaste Note Added: 0006542
21.04.2014 14:16 grayman Note Added: 0006543
21.04.2014 15:15 AluminumHaste Note Added: 0006544
21.04.2014 15:24 AluminumHaste Note Added: 0006545
23.05.2014 00:14 grayman Assigned To => grayman
23.05.2014 00:14 grayman Status new => assigned
23.05.2014 03:28 grayman Note Added: 0006619
23.05.2014 03:29 grayman Note Edited: 0006619 View Revisions
23.05.2014 23:14 grayman Note Added: 0006620
23.05.2014 23:14 grayman Status assigned => resolved
23.05.2014 23:14 grayman Resolution open => fixed
23.05.2014 23:14 grayman Fixed in Version => TDM 2.02
23.05.2014 23:21 grayman Note Edited: 0006620 View Revisions