View Issue Details

IDProjectCategoryView StatusLast Update
0003662The Dark ModTexturespublic10.01.2019 02:00
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.00 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0003662: NoFog material keyword not working
DescriptionAdding "nofog" to a material shader is supposed to stop that surface from being affected by fog. Since 2.0 it has stopped working.

TagsNo tags attached.

Relationships

related to 0003664 resolvedSteveL Change caulk so that it ignores fog. 
related to 0004951 resolvednbohr1more Z-fighting with shadow textures when foglight present 

Activities

rebb

rebb

26.01.2014 16:46

developer   ~0006357

Last edited: 26.01.2014 20:09

View 3 revisions

Are you sure this ever worked pre 2.0 ?

NoFog does nothing even in the default Doom3 Code release, except in one DMAP function that is related to light-carving.

But maybe that just means that the map has to be recompiled for NoFog to apply.

rebb

rebb

26.01.2014 16:50

developer   ~0006358

Yeah looks like the only place where it comes into play is DMAP when lightCarving is enabled.
grayman

grayman

26.01.2014 19:00

administrator   ~0006359

TDM's use of "noFog" is exactly the same as it was in D3.

So this wasn't broken in 2.00; it never worked in the first place.
Springheel

Springheel

26.01.2014 23:37

administrator   ~0006363

Ah, okay.

I'm not sure how useful the function is, _except_ as a way to fix the foglight vs caulk issue (and there's no guarrantee it would even do that).

Maybe I should file a different feature request.
nbohr1more

nbohr1more

10.01.2019 01:59

developer   ~0011285

2.07 beta

Rev 7905
nbohr1more

nbohr1more

10.01.2019 01:59

developer  

heartv2_2019-01-09_20.43.15.jpg (361,580 bytes)

Issue History

Date Modified Username Field Change
26.01.2014 15:50 Springheel New Issue
26.01.2014 16:46 rebb Note Added: 0006357
26.01.2014 16:48 rebb Note Edited: 0006357 View Revisions
26.01.2014 16:50 rebb Note Added: 0006358
26.01.2014 19:00 grayman Note Added: 0006359
26.01.2014 20:09 rebb Note Edited: 0006357 View Revisions
26.01.2014 23:37 Springheel Note Added: 0006363
27.01.2014 16:18 Springheel Status new => closed
27.01.2014 16:18 Springheel Assigned To => Springheel
27.01.2014 16:18 Springheel Resolution open => fixed
27.01.2014 16:18 Springheel Relationship added related to 0003664
09.01.2019 20:38 nbohr1more Relationship added related to 0004951
10.01.2019 01:59 nbohr1more Note Added: 0011285
10.01.2019 01:59 nbohr1more File Added: heartv2_2019-01-09_20.43.15.jpg
10.01.2019 02:00 nbohr1more Status closed => resolved
10.01.2019 02:00 nbohr1more Fixed in Version => TDM 2.07
10.01.2019 02:00 nbohr1more Target Version => TDM 2.07