View Issue Details

IDProjectCategoryView StatusLast Update
0003666The Dark ModPhysicspublic14.09.2017 03:15
Reportersotha_sil Assigned ToSteveL  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionunable to reproduce 
Product VersionTDM 2.00 
Fixed in VersionTDM 2.04 
Summary0003666: Touching stacked moveables causes a crash
DescriptionIn OldHabits2 (the remake), there is a shack you gotta
sneak in from the back.

Inside the shack there are some bottles and shattered glassware on the floor. (On top of a straw mattress.)

If I touch or try to move some of the glassware, most of the items start to collide into each other and TDM grinds to a halt. It freezes and I have to kill it with task manager.
Savegame is available, attached.
(crash.zip)
I used TDM 2.0, and the mission I downloaded from the internal downloader 28.1.2014.

I'm inclined to think it may be a new bug; no way that could have slipped through the beta testing. I tried four times and I got the lockup every time.

The savegame gets you straight into the shack and your view is pointed at the glassware. Touch it and it would crash.
Steps To ReproduceThe savegame gets you straight into the shack and your view is pointed at the glassware. Touch it and it would crash.
TagsNo tags attached.

Relationships

related to 0004061 resolvedSteveL Crash when reloading or shutting map down while glass is falling.  

Activities

sotha_sil

sotha_sil

28.01.2014 21:51

reporter  

crash.zip (3,575,130 bytes)
nbohr1more

nbohr1more

14.09.2017 03:14

developer   ~0009221

I cannot reproduce this.

This was almost certainly fixed in 2.03 or 2.04 where breakable\glass code was fixed.

Issue History

Date Modified Username Field Change
28.01.2014 21:51 sotha_sil New Issue
28.01.2014 21:51 sotha_sil File Added: crash.zip
14.09.2017 03:08 nbohr1more Relationship added related to 0004061
14.09.2017 03:14 nbohr1more Note Added: 0009221
14.09.2017 03:15 nbohr1more Assigned To => SteveL
14.09.2017 03:15 nbohr1more Status new => closed
14.09.2017 03:15 nbohr1more Resolution open => unable to reproduce
14.09.2017 03:15 nbohr1more Fixed in Version => TDM 2.04