View Issue Details

IDProjectCategoryView StatusLast Update
0003682The Dark ModCodingpublic15.04.2014 21:06
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.01 
Target VersionTDM 2.02Fixed in VersionTDM 2.02 
Summary0003682: AI Hearing slider
DescriptionNow that the sound/info_location bug is fixed, AI are hearing noticeably better in most maps. This is likely to cause frustration as players suddenly find AI much more sensitive. If they've been primarily playing the maps that use info_location entities (the majority of maps) then this will seem like a very noticeable change.

An audio slider could either modify the audio_threshold value of AI, or the code that determines how quickly sounds degrade.

Matching the existing Vision options makes sense. "Challenging" would be the default, and use the properly fixed sound settings as they are now. "Forgiving" would try to match the bugged sound that players are used to in most maps. And then "Nearly Deaf" and "Hardcore" modes could be added as well.
TagsNo tags attached.

Activities

grayman

grayman

04.04.2014 22:59

administrator   ~0006492

Any interest in replacing the current "AI Vision" slider with "AI Alertness" or "AI Senses" and having it control both hearing and vision?
Springheel

Springheel

05.04.2014 01:10

administrator   ~0006494

Last edited: 05.04.2014 01:10

View 2 revisions

I'm torn. On the one hand it makes sense to combine them and it saves space in the menu. But on the other hand, vision and hearing are not equally weighted as it stands now. The current default for Vision is "Forgiving". I don't think the current default for sound would be suitable for that option...it's actually at "Challenging". Hearing has a greater impact on gameplay than vision as well...if you bump hearing up beyond where it is now, it will become nearly impossible to KO guards on loud surfaces. I can imagine someone wanting Hardcore vision, but not necessarily wanting Hardcore sound.

I guess I'm leaning more towards keeping them separate, but my reasons aren't very strong if I'm in the minority.

grayman

grayman

05.04.2014 02:11

administrator   ~0006495

Thinking out loud ...

Existing maps fall into two categories:

1 - Those w/o location entities experience the correct sound loss.

2 - Those with location entities experience the incorrect sound loss.

Starting in 2.02, both categories will experience the correct sound loss.

If we want "Forgiving" to mimic the incorrect sound loss, we only want that to affect the maps in category 2; if we apply the same "Forgiving" factor to both categories, the maps in category 1 would be broken.

So the solution has to take this into account.
Springheel

Springheel

05.04.2014 03:04

administrator   ~0006496

They wouldn't be broken, but they would be easier than they are currently. The sound settings have to be consistent, so there's no way to avoid making some maps easier or harder than they are now.
grayman

grayman

06.04.2014 17:23

administrator   ~0006504

Since we don't have room on the menu for any more options, how do you want to handle the addition of AI Hearing?
grayman

grayman

06.04.2014 22:49

administrator   ~0006509

One possibility is to break the Gameplay menu into two submenus called General and Difficulty.

Difficulty would include AI Vision, AI Hearing, Lockpicking, and Combat Difficulty.

General would include the rest.

Another possibility is to push the squiggly dividing line up under Audio/Video/Gameplay/Controls, making room for two more options. We use one for AI Hearing, leaving one more for the future.
Springheel

Springheel

07.04.2014 00:32

administrator   ~0006510

Of those I think the sub-menu idea is preferable (more future-proof).
grayman

grayman

07.04.2014 00:35

administrator   ~0006511

I'll implement the sub-menu design.

For now, I'll make the hearing factor a multiplier of the AI's visual acuity, which is the simplest approach.

Considering these values:

Nearly Deaf - 0.6
Forgiving - 0.8
Challenging - 1.0
Hardcore - 1.2

Like we did with the AI Vision setting, we can adjust this during beta testing.
grayman

grayman

07.04.2014 15:53

administrator   ~0006512

Divided the Gameplay menu into two sub-menus: “General” and “Difficulty”. Added the “AI Hearing” slider to the “Difficulty” page. Created four levels of difficulty:

Nearly Deaf = 0.6
Forgiving = 0.8
Challenging = 1.0 (default)
Hardcore = 1.2

These multipliers are applied to each AI’s audio acuity. We can adjust them during the 2.02 beta test.

Rev. 5948:

AI.cpp
SysCvar.cpp
SysCvar.h
Game_local.cpp

Rev. 13789:

mainmenu_defs.gui
mainmenu_settings.gui
mainmenu_settings_gameplay.gui
devel/release/Darkmod.cfg
*.lang

Issue History

Date Modified Username Field Change
06.03.2014 14:02 Springheel New Issue
06.03.2014 14:07 Springheel Description Updated View Revisions
04.04.2014 20:28 Springheel Target Version TDM 2.01 => TDM 2.02
04.04.2014 22:59 grayman Note Added: 0006492
05.04.2014 01:10 Springheel Note Added: 0006494
05.04.2014 01:10 Springheel Note Edited: 0006494 View Revisions
05.04.2014 02:11 grayman Note Added: 0006495
05.04.2014 03:04 Springheel Note Added: 0006496
06.04.2014 17:20 grayman Assigned To => grayman
06.04.2014 17:20 grayman Status new => assigned
06.04.2014 17:23 grayman Note Added: 0006504
06.04.2014 22:49 grayman Note Added: 0006509
07.04.2014 00:32 Springheel Note Added: 0006510
07.04.2014 00:35 grayman Note Added: 0006511
07.04.2014 15:53 grayman Note Added: 0006512
07.04.2014 15:53 grayman Status assigned => feedback
07.04.2014 15:53 grayman Resolution open => fixed
07.04.2014 15:53 grayman Fixed in Version => TDM 2.02
15.04.2014 21:06 grayman Status feedback => resolved