View Issue Details

IDProjectCategoryView StatusLast Update
0003705The Dark ModAIpublic08.07.2014 14:14
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.01 
Target VersionTDM 2.02Fixed in VersionTDM 2.02 
Summary0003705: AI freeze during alert 5 charge
DescriptionI was testing my map to see where AI could reach me when chasing me and where they couldn't. In two different places I pushed back into a corner, and the AI ran up to me and simply froze in place in mid run about two steps away from me. It actually looked like they were playing two frames of the run animation, as they were 'jittering' rather than perfectly still like a screenshot. However, they both hung in place not moving.

In the first case, if I took one step forward the AI resumed its attack, and then it would freeze again if I took a single step backwards. (the second place it happened my system crashed).

In the first case, when I took a single small step forward, the AI's feet started "jittering" the way they sometimes do when they try to path too close to monsterclip.

In both cases I was about 60 units deep into monsterclip.

TagsNo tags attached.

Activities

grayman

grayman

18.04.2014 17:00

administrator   ~0006535

I can't reproduce this.

I have myself at one end of a simple room with 64-wide monsterclip forming a corner in one of the room's corners behind me.

At the other end of the room is a guard.

He spots me and charges, pulling out his sword.

If I step back against the wall behind me, into the monsterclip, the guard stops, sheathes his weapon, and starts throwing rocks.

Step out, he comes for me again.

Step back, he stops and starts throwing.

Do you have a test map showing the problem?
Springheel

Springheel

22.04.2014 13:26

administrator   ~0006547

It was occuring in my map during testing, but I fixed the monsterclip in the area. I'll see if I can get it to happen again.
Springheel

Springheel

13.05.2014 16:14

administrator   ~0006605

Last edited: 13.05.2014 16:19

View 2 revisions

I haven't had it occur in a map yet, but I did notice it in a recent LP posted on Youtube. If you look at the following video and scroll to 14:23, you'll see that the alerted guard appears frozen, jittering one frame back and forth. The fact that he then attacks as soon as the player leans suggests to me that he's in the middle of switching to combat mode, but that the player's position is causing some kind of problem. The moment the player leans, the problem goes away and the AI attacks as normal.

When I experienced it, the AI was already charging in combat mode, but the frozen posture and 'jittering' back and forth was the same as seen here.

https://www.youtube.com/watch?v=89nOwhzjCxc&index=80&list=WL

grayman

grayman

13.05.2014 16:55

administrator   ~0006606

Though the video shows the jitter, there are no visual clues as to what's causing it. The monsterclip around the crate has the same dimensions as the crate, so it's unlikely the player is off the AAS grid. So it might not be the same problem.

To solve this, I'm going to need a savegame showing the problem. There are too many factors involved.
Springheel

Springheel

21.05.2014 01:07

administrator   ~0006612

Last edited: 21.05.2014 01:14

View 6 revisions

Ok, this happened while testing today. There are two AI right in front of me, both of them staring right at me and 'jittering' back and forth between frames of an animation.

http://www.mindplaces.com/glitch.zip

grayman

grayman

21.05.2014 01:31

administrator   ~0006613

After updating to Obs' latest Sikkmod commit this morning, I've been unable to build anything I can debug with.

As soon as we work through the issues and I can build again, I'll try to see what's going on here.
grayman

grayman

22.05.2014 02:07

administrator   ~0006616

The problem is that the AI ramps up to Combat, then there’s not enough light for him to see the player, so he drops back to AgitatedSearching, where he checks player visibility differently. Now he sees just enough of the player to push him back into Combat, where he loses sight of him again, and drops back to AgitatedSearching. This cycle is repeating about once per second, causing the observed twitching.

Changed the player visibility check when in Combat so it more closely matches the visibility check done as the AI is ramping up to Combat. Now, when the AI enters Combat, he stays there unless the player’s visibility drops off to where the AI can’t see the player in any state.

Rev. 6009:

CombatState.cpp


grayman

grayman

22.05.2014 02:10

administrator   ~0006617

Last edited: 22.05.2014 02:11

View 2 revisions

I think my original assumption that this was a "player's in monsterclip" problem was wrong. All my tests with moving in and out of monsterclip resulted in the AI doing the right thing: either coming after me or stopping to throw stones.

The problem was that the player was visible enough for AgitatedSearching to see him, but not visible enough for Combat to hang onto him, so he quickly toggled back and forth between the two states, which caused the jitter.

grayman

grayman

08.07.2014 14:14

administrator   ~0006703

No sightings in the 2 months after the fix, so I'm resolving this one.

Issue History

Date Modified Username Field Change
03.04.2014 01:03 Springheel New Issue
03.04.2014 01:31 Springheel Description Updated View Revisions
18.04.2014 17:00 grayman Note Added: 0006535
18.04.2014 17:00 grayman Assigned To => grayman
18.04.2014 17:00 grayman Status new => assigned
22.04.2014 13:22 grayman Status assigned => feedback
22.04.2014 13:26 Springheel Note Added: 0006547
22.04.2014 13:26 Springheel Status feedback => assigned
13.05.2014 16:14 Springheel Note Added: 0006605
13.05.2014 16:19 Springheel Note Edited: 0006605 View Revisions
13.05.2014 16:55 grayman Note Added: 0006606
21.05.2014 01:07 Springheel Note Added: 0006612
21.05.2014 01:11 Springheel Note Edited: 0006612 View Revisions
21.05.2014 01:13 Springheel Note Edited: 0006612 View Revisions
21.05.2014 01:13 Springheel Note Edited: 0006612 View Revisions
21.05.2014 01:14 Springheel Note Edited: 0006612 View Revisions
21.05.2014 01:14 Springheel Note Edited: 0006612 View Revisions
21.05.2014 01:31 grayman Note Added: 0006613
22.05.2014 02:07 grayman Note Added: 0006616
22.05.2014 02:07 grayman Status assigned => feedback
22.05.2014 02:07 grayman Resolution open => fixed
22.05.2014 02:07 grayman Fixed in Version => TDM 2.02
22.05.2014 02:07 grayman Target Version => TDM 2.02
22.05.2014 02:10 grayman Note Added: 0006617
22.05.2014 02:11 grayman Note Edited: 0006617 View Revisions
08.07.2014 14:14 grayman Note Added: 0006703
08.07.2014 14:14 grayman Status feedback => resolved