View Issue Details

IDProjectCategoryView StatusLast Update
0003738The Dark ModAIpublic28.05.2014 11:41
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.02 
Target VersionTDM 2.02Fixed in VersionTDM 2.02 
Summary0003738: Certain pickpocketed objects should not elicit a reaction from an AI
Description2.02 includes a new "react to having a pocket picked" feature.

Certain objects should not cause the AI to react. For example, he shouldn't notice when an arrow is plucked from a quiver on his back, since he has many more arrows in the quiver.

So we need a spawnarg for objects like this.

"notice_when_stolen" "1" - react when this is stolen (default)

"notice_when_stolen" "0" - don't react when this is stolen

A setting of "1" doesn't guarantee a reaction, since there are other rules in place that determine whether a reaction occurs or not.
TagsNo tags attached.

Activities

grayman

grayman

28.05.2014 03:39

administrator   ~0006642

Last edited: 28.05.2014 11:31

View 2 revisions

Afterthought: Would a stolen arrow register as a picked pocket? The arrow is attached to the quiver, and the quiver to the AI. Stolen items are only registered if they're directly attached to the AI.

Edit: No, they're not, but it's due to ammunition being handled differently, and not considered objects that can be pickpocketed.

grayman

grayman

28.05.2014 11:41

administrator   ~0006643

Added a “notice_when_stolen” spawnarg for items that can be stolen from AI but shouldn’t cause the AI to react.

Rev. 6020:

MissionData.cpp

Issue History

Date Modified Username Field Change
28.05.2014 03:26 grayman New Issue
28.05.2014 03:26 grayman Status new => assigned
28.05.2014 03:26 grayman Assigned To => grayman
28.05.2014 03:39 grayman Note Added: 0006642
28.05.2014 11:31 grayman Note Edited: 0006642 View Revisions
28.05.2014 11:41 grayman Note Added: 0006643
28.05.2014 11:41 grayman Status assigned => resolved
28.05.2014 11:41 grayman Resolution open => fixed
28.05.2014 11:41 grayman Fixed in Version => TDM 2.02