View Issue Details

IDProjectCategoryView StatusLast Update
0003743DarkRadiantGeneralpublic15.02.2015 13:14
Reporterkordex Assigned Togreebo  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSWindows 8.1 and Fedora 20OS Versionabove
Product Version1.8.0 
Target Version2.0.0Fixed in Version2.0.0 
Summary0003743: Following def file causes particle editor to exit unexpectedly
Descriptionmodel model_player {
    mesh "models/player/player.md5mesh"
}

entityDef worldspawn {
    "spawnclass" "idWorldspawn"
    "name" "world"
}

entityDef player_doommarine {
    "spawnclass" "idPlayer"
    "scriptobject" "player"

    "def_weapon0" "weapon_fists"
    "def_weapon1" "weapon_fists"

    "bone_hips" "Hips"
    "bone_chest" "Shoulders"
    "bone_head" "headcontrol"

    "model" "model_player"
}
Steps To Reproducesave contents of describtion to default.def under def directory and restart darkradiant, launch particle editor and see it fail
TagsNo tags attached.

Activities

kordex

kordex

03.06.2014 21:49

reporter   ~0006654

actually one is able to reproduce this even without that file. just open plain darkradiant and point it to an empty directory and try to save new particle
greebo

greebo

18.07.2014 17:23

administrator   ~0006731

I can't reproduce the issue on my end - I copied the default.def with the contents above to the def/ folder and I also tried to save a new particle "testparticle" to an empty particles/ folder - no crash so far. Is there something else I need to set up, perhaps?
kordex

kordex

18.07.2014 19:50

reporter   ~0006736

please open darkradiant and point it to an empty directory and try to save new particle. I mean no doom installed or anything else.
greebo

greebo

19.07.2014 06:03

administrator   ~0006737

Last edited: 19.07.2014 06:03

View 2 revisions

I see, it's because the entityDef func_emitter is not present. I can only try to catch that error and display a messagebox, but the editor probably won't function correctly.

greebo

greebo

19.07.2014 07:09

administrator   ~0006738

Crash prevented in case no func_emitter eclass can be found.

Issue History

Date Modified Username Field Change
03.06.2014 21:40 kordex New Issue
03.06.2014 21:49 kordex Note Added: 0006654
05.06.2014 08:49 greebo Status new => acknowledged
18.07.2014 17:23 greebo Note Added: 0006731
18.07.2014 17:23 greebo Status acknowledged => feedback
18.07.2014 19:50 kordex Note Added: 0006736
18.07.2014 19:50 kordex Status feedback => new
19.07.2014 06:03 greebo Note Added: 0006737
19.07.2014 06:03 greebo Status new => confirmed
19.07.2014 06:03 greebo Note Edited: 0006737 View Revisions
19.07.2014 07:09 greebo Note Added: 0006738
19.07.2014 07:09 greebo Status confirmed => resolved
19.07.2014 07:09 greebo Fixed in Version => 2.0.0
19.07.2014 07:09 greebo Resolution open => fixed
19.07.2014 07:09 greebo Assigned To => greebo
19.07.2014 07:09 greebo Target Version => 2.0.0
15.02.2015 13:14 greebo Status resolved => closed