View Issue Details

IDProjectCategoryView StatusLast Update
0003768The Dark ModSound Systempublic19.08.2017 20:47
ReporterRJFerret Assigned Tograyman  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7
Product VersionTDM 2.02 
Target VersionTDM 2.03Fixed in VersionTDM 2.03 
Summary0003768: 2.02 sound difficulty breaks few maps at start player drop
DescriptionWith the new 2.02 Sound Difficulty set to "Hardcore" or "Challenging", the sound caused by the player start dropping into the map alerts AI. In Hardcore, it causes them to fully alert and attack the player, preventing the map from being able to be run without workarounds. In Challenging, it alerts AI.

I checked about twenty maps (alphabetically, skipping a couple puzzle maps) and three were affected.
Steps To Reproduce1. Set Sound Difficulty to Hardcore (or Challenging).
2. Load Beleaguered Fence, Alchemist or Betrayal.
3. Start map.
4. Observe attacking AI (or alerted if set to Challenging).
Additional InformationWorkarounds include using "notarget" before clicking to start the map, or changing settings to lower, starting the map, then changing the settings back to Hardcore.
TagsNo tags attached.

Relationships

related to 0004609 resolvedgrayman Beleaguered Fence AI alerted again at map start 

Activities

grayman

grayman

30.06.2014 20:08

administrator   ~0006692

What do you think should change?

To many people, Alchemist was always "run!" anyway.
RJFerret

RJFerret

30.06.2014 20:39

reporter   ~0006696

Well in "Beleaguered" at least, it means an inability to play the mission, depending which tools were unknowingly purchased before starting.

Springheel suggested perhaps instituting a delay in the forum thread on this.

Depending what is easiest/least ramifications, either an outright delay, or ramp in the setting from default, cheesy would be a notification if those settings are chosen that it might break some maps; but I don't know what the options are, my ignorance precludes offering an optimal solution. Or would it be easier/reasonable for that initial drop sound from player start not propagate to AI?

Of course, the other solution is to ask for the affected maps to be changed, to either have the player start on ground, change the surface underfoot (which if surface material volumes are changed again in the future...), or move the nearby AI to accommodate the 2.01->2.02 change and return those maps back to playing how they were designed.

PS: Oh! Of course it might be possible a lower setting might alter the game-play of the maps but not break them. For instance, Challenging in "Beleaguered" alerts AI, affecting the game-play, but at least allows running the map.

However it would be very time consuming to determine all the maps broken in this condition, figure out the maximum setting that works for the worst of them, then scale the difficulty values accordingly.
grayman

grayman

21.07.2014 15:49

administrator   ~0006770

Don’t allow sounds to propagate in the first 60 frames (one second).

Rev. 6069:

Entity.cpp
grayman

grayman

21.07.2014 15:52

administrator   ~0006771

While 60 frames might seem a long time, the beginning of Beleaguered Fence is filled with ragdolls dropping in the jail cells. This upsets the jailer who's walking around down there, and he starts the mission searching around.

I wanted to test Heart, because that seems to be the longest player drop at any mission's start. But Heart crashed. I filed a new tracker issue for it.

Issue History

Date Modified Username Field Change
29.06.2014 16:21 RJFerret New Issue
30.06.2014 09:49 SteveL Product Version TDM 2.01 => TDM 2.02
30.06.2014 20:08 grayman Note Added: 0006692
30.06.2014 20:39 RJFerret Note Added: 0006696
21.07.2014 15:24 grayman Assigned To => grayman
21.07.2014 15:24 grayman Status new => assigned
21.07.2014 15:49 grayman Note Added: 0006770
21.07.2014 15:49 grayman Status assigned => resolved
21.07.2014 15:49 grayman Resolution open => fixed
21.07.2014 15:49 grayman Fixed in Version => TDM 2.03
21.07.2014 15:49 grayman Target Version => TDM 2.03
21.07.2014 15:52 grayman Note Added: 0006771
19.08.2017 20:47 grayman Relationship added related to 0004609