View Issue Details

IDProjectCategoryView StatusLast Update
0003861The Dark ModDesign/Codingpublic25.04.2018 03:11
Reportertels Assigned Totaaaki  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionopen 
Product VersionTDM 1.08 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0003861: default config has commands that are not understood
DescriptionThe default.cfg has some commands that the engine does not correctly understand. This leads to warnings on the console, and presumable also executes some things not properly:

execing default.cfg
Unknown command 'use'
Unknown command 'console'
Unknown command 'next'
Unknown command 'prev'
Unknown command 'previous'
Unknown command 'next'
Unknown command 'crouch'
Unknown command 'Lean'
Unknown command 'lean'
Unknown command 'Readables'
Unknown command 'spyglass'
Unknown command 'compass'
Unknown command 'lantern'
Unknown command 'maps'
Unknown command 'objectives'
Unknown command 'keys'
Unknown command 'lockpicks'
Unknown command 'lean'
Unknown command 'Inventory'
Unknown command 'Mantle'
Unknown command 'creep'
Unknown command 'frob'
Unknown command 'inventory'
execing Darkmod.cfg
Steps To ReproduceStart TDM and read the console output
Additional Informationhttp://forums.thedarkmod.com/topic/16594-crash-to-desktop-when-downloading-missions-linux/page__pid__355493#entry355493
TagsNo tags attached.

Relationships

duplicate of 0003266 closed default.cfg does not know commands, only keybinds 

Activities

SteveL

SteveL

03.10.2014 16:50

developer   ~0007040

I don't get those errors. Could this be a problem just on Linux? No reason to think so other than that the reporter was using Linux too.
tels

tels

05.10.2014 11:02

developer   ~0007052

Maybe your default.cfg is different, or you have one that is overring the one in tdm_base.pk4? Or maybe on Windows the warnings don't appear?

A quick look shows that these warnings come from the first word after a ";", which should be comments. However, ";" is the "at the end of the command" char, so it "; use" is parsed as "delimiter-command 'use'".

The right way for comments is "//".

Please find attached a patch that fixes this issue.
tels

tels

05.10.2014 11:03

developer  

tels_patch_o_default_cfg_2014-10-05.txt (2,276 bytes)   
--- default.cfg.org	2012-10-09 07:04:12.000000000 +0200
+++ default.cfg	2014-10-05 12:59:33.000000000 +0200
@@ -1,11 +1,11 @@
 unbindall
-; use inventory item
+// use inventory item
 bind "ENTER" "_impulse51"
 bind "ESCAPE" "togglemenu"
 bind "SPACE" "_moveup"
-; console
+// console
 bind "^" "_impulse0"
-; next inv group
+// next inv group
 bind "-" "_impulse50"
 bind "0" "_impulse10"
 bind "1" "_impulse1"
@@ -17,45 +17,45 @@
 bind "7" "_impulse7"
 bind "8" "_impulse8"
 bind "9" "_impulse9"
-; prev inv group
+// prev inv group
 bind "=" "_impulse49"
-; previous item
+// previous item
 bind "[" "_impulse48"
 bind "\" "_mlook"
-; next item
+// next item
 bind "]" "_impulse47"
 bind "a" "_moveleft"
-; crouch
+// crouch
 bind "x" "_impulse23"
 bind "d" "_moveright"
-; Lean Right 
+// Lean Right 
 bind "e" "_impulse46"
-; lean forward
+// lean forward
 bind "f" "_impulse44"
-; Readables
+// Readables
 bind "i" "inventory_cycle_group '#str_02391'"
-; spyglass
+// spyglass
 bind "g" "inventory_use '#str_02396'"
-; compass
+// compass
 bind "v" "inventory_hotkey '#str_02397'"
-; lantern
+// lantern
 bind "l" "inventory_use '#str_02395'"
-; maps
+// maps
 bind "m" "inventory_cycle_maps"
-; objectives
+// objectives
 bind "o" "_impulse19"
-; keys
+// keys
 bind "k" "inventory_cycle_group '#str_02392'"
-; lockpicks
+// lockpicks
 bind "p" "inventory_cycle_group '#str_02389'"
-; lean left
+// lean left
 bind "q" "_impulse45"
-; Inventory Drop item
+// Inventory Drop item
 bind "r" "_impulse52"
 bind "s" "_back"
 bind "u" "_impulse19"
 bind "w" "_forward"
-; Mantle (without jumping)
+// Mantle (without jumping)
 bind "c" "_impulse24"
 bind "y" "clientMessageMode 1"
 bind "z" "_zoom"
@@ -66,7 +66,7 @@
 bind "LEFTARROW" "_left"
 bind "RIGHTARROW" "_right"
 bind "ALT" "_strafe"
-; creep
+// creep
 bind "CTRL" "_button5"
 bind "SHIFT" "_speed"
 bind "DEL" "_lookdown"
@@ -80,10 +80,10 @@
 bind "F9" "loadgame quick"
 bind "F12" "screenshot"
 bind "MOUSE1" "_attack"
-; frob
+// frob
 bind "MOUSE2" "_impulse41"
 bind "MOUSE3" "_zoom"
 bind "MWHEELDOWN" "_impulse14"
 bind "MWHEELUP" "_impulse15"
-; inventory use item
+// inventory use item
 bind "u" "_impulse51"
SteveL

SteveL

05.10.2014 15:36

developer   ~0007056

Ah, it's already fixed in svn that's why. There are no comments at all in the file. But the current file version pre-dates 2.02, so presumably this file doesn't get packaged.

grayman, when you package 2.03 could you check that the default.cfg from svn goes into tdm_base01.pk4 please?
tels

tels

05.10.2014 16:36

developer   ~0007058

And could you also please re-add the comments? There is no reason to throw them out ;)
grayman

grayman

05.10.2014 18:36

administrator   ~0007061

Does the attached patch apply to the latest rev of default.cfg?
SteveL

SteveL

06.10.2014 13:50

developer   ~0007062

It applies to the version in tdm_base01.pk4 which is different from the svn version.

svn version has no comments in it, so it doesn't issue warnings. The game pk4 has comments but they have bad syntax so create warnings.

Tel's patch could be used on the one in the pk4. Alternatively the pk4 version could simply have all semi-colons replaced with a // to fix it. Or the version from svn could be packaged intead, but then we'd have no comments in it.
grayman

grayman

06.10.2014 18:30

administrator   ~0007063

I added the comments to SVN's default.cfg, in the darkmod folder.

As for the request that 2.03 include this in tdm_base01.pk4, that's already specified in devel/manifests/darkmod_pk4s.txt.

Is this all that needs to be done?
SteveL

SteveL

09.10.2014 17:25

developer   ~0007066

I'm confused... The svn version of the file didn't have the bad comments that caused the errors (starting with ';' instead of '//'), but the file predated 2.02 by quite a bit. So how come the file didn't get packaged without comments in 2.02?

That was why I asked that you made sure it got packaged. I concluded that it must be missing from the packaging script.
grayman

grayman

09.10.2014 17:50

administrator   ~0007067

Not sure why that happened.

We'll keep an eye on the file when we build 2.03.
nbohr1more

nbohr1more

28.09.2017 01:18

developer   ~0009357

Changed the comment in Rev 14966

The premise of some of this discussion is that this file is not packed with release branches.

My 2.05 install has this file. If we are shipping it we might as well fix it.
nbohr1more

nbohr1more

25.04.2018 03:11

developer   ~0010396

Rev 15188

Copied to devel so it gets into the package.

Issue History

Date Modified Username Field Change
03.10.2014 09:46 tels New Issue
03.10.2014 16:50 SteveL Note Added: 0007040
05.10.2014 11:02 tels Note Added: 0007052
05.10.2014 11:03 tels Assigned To => SteveL
05.10.2014 11:03 tels Status new => confirmed
05.10.2014 11:03 tels Product Version => TDM 1.08
05.10.2014 11:03 tels Target Version => TDM 2.03
05.10.2014 11:03 tels File Added: tels_patch_o_default_cfg_2014-10-05.txt
05.10.2014 15:36 SteveL Note Added: 0007056
05.10.2014 15:36 SteveL Assigned To SteveL => grayman
05.10.2014 15:36 SteveL Status confirmed => assigned
05.10.2014 16:36 tels Note Added: 0007058
05.10.2014 18:36 grayman Note Added: 0007061
06.10.2014 13:50 SteveL Note Added: 0007062
06.10.2014 18:30 grayman Note Added: 0007063
09.10.2014 17:25 SteveL Note Added: 0007066
09.10.2014 17:50 grayman Note Added: 0007067
30.10.2014 14:25 grayman Status assigned => feedback
27.09.2017 16:55 nbohr1more Relationship added duplicate of 0003266
28.09.2017 01:18 nbohr1more Note Added: 0009357
28.09.2017 01:18 nbohr1more Status feedback => resolved
28.09.2017 01:18 nbohr1more Fixed in Version => TDM 2.06
28.09.2017 01:18 nbohr1more Target Version TDM 2.03 => TDM 2.06
28.09.2017 01:20 nbohr1more Assigned To grayman => taaaki
25.04.2018 03:11 nbohr1more Note Added: 0010396