View Issue Details

IDProjectCategoryView StatusLast Update
0004031DarkRadiantMap Editingpublic25.06.2016 13:13
Reporteruser81Assigned Touser81 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.3 
Fixed in Version2.0.4 
Summary0004031: Intermittent crash in Prefab Selector
DescriptionSee notes, but in summary -

# Grayman is seing crashes when inserting prefabs and models
# I am seeing what appear to be random CTD's, but it could be the same issue as Grayman's
TagsNo tags attached.

Relationships

has duplicate 0004136 closed Prefab import dialogue crashes 

Activities

user81

07.07.2015 09:44

  ~0007625

Will check and see if this still happens in 203pre5
grayman

grayman

21.08.2015 13:01

administrator   ~0007725

Last edited: 21.08.2015 13:02

View 2 revisions

I just opened DR 2.02 (built Jan 10 2015) on a new map to test some prefabs.

Insert one prefab of a wooden chest.

Right-click and select "insert prefab" (to insert a different chest).

The prefab window appears, and DR crashes.

Happens every time.

grayman

grayman

21.08.2015 13:06

administrator   ~0007726

I get random DR crashes when using the "create model" feature. These crashes can take hours to occur, however. My workaround is to always save when I know I'm about to create a new model.

Hopefully, fixing the prefab crashes will fix the model crashes.

user81

09.10.2015 15:22

  ~0007843

just an update to this, in the latest version of DR(2.0.3pre 5/6) DR is doing a lot of CTD's so went back to 1.8.1. When Orb/Greebo come back to working on DR I will get back to narrowing down is causing the CTD's if it isnt the above prefab/model crash.
greebo

greebo

29.12.2015 09:13

administrator   ~0007929

In the most recent build I have here, I can't reproduce the crash by following the steps as provided by Grayman in #c7725.
greebo

greebo

29.12.2015 09:14

administrator   ~0007930

If anyone can provide a crashdump when this stuff occurs, I'm happy to look into it, but you need to be using the version as provided in the pre-release thread.
greebo

greebo

25.06.2016 12:50

administrator   ~0008218

Are we safe from these kind of crashes in the meantime?

user81

25.06.2016 13:09

  ~0008221

I haven't seen any prefab related crashed since 2.04

user81

25.06.2016 13:13

  ~0008224

see last note.

Issue History

Date Modified Username Field Change
12.01.2015 03:24 greebo New Issue
12.01.2015 03:24 greebo Reporter greebo => user81
12.01.2015 03:24 greebo Status new => acknowledged
07.07.2015 09:44 user81 Note Added: 0007625
21.08.2015 13:01 grayman Note Added: 0007725
21.08.2015 13:02 grayman Note Edited: 0007725 View Revisions
21.08.2015 13:06 grayman Note Added: 0007726
21.08.2015 13:15 grayman Relationship added has duplicate 0004136
09.10.2015 15:22 user81 Note Added: 0007843
09.10.2015 15:25 user81 Reproducibility have not tried => always
09.10.2015 15:25 user81 Product Version 2.0.2 => 2.0.3
09.10.2015 15:25 user81 Description Updated View Revisions
09.10.2015 15:25 user81 Description Updated View Revisions
09.10.2015 15:27 user81 Assigned To => user81
09.10.2015 15:27 user81 Status acknowledged => assigned
29.12.2015 09:13 greebo Note Added: 0007929
29.12.2015 09:14 greebo Note Added: 0007930
25.06.2016 12:50 greebo Note Added: 0008218
25.06.2016 12:50 greebo Assigned To user81 =>
25.06.2016 12:50 greebo Status assigned => feedback
25.06.2016 13:09 user81 Note Added: 0008221
25.06.2016 13:09 user81 Status feedback => new
25.06.2016 13:13 user81 Note Added: 0008224
25.06.2016 13:13 user81 Status new => closed
25.06.2016 13:13 user81 Assigned To => user81
25.06.2016 13:13 user81 Resolution open => fixed
25.06.2016 13:13 user81 Fixed in Version => 2.0.4