View Issue Details

IDProjectCategoryView StatusLast Update
0004094The Dark ModAnimationpublic15.12.2018 19:52
ReporterDunedain19 Assigned ToSpringheel  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product VersionTDM 2.03 
Summary0004094: Blackjack 'Attack Cancel' Animation Glitch
DescriptionBy design, TDM allows the player to holster their selected weapon. If I am about to swing my sword or fire an arrow at a guard, but then decide against this action - I can simply press the key assigned to 'Parry' and the character cancels the intended strike or "de-nocks" the arrow.

The same applies for the blackjack, which the player can raise and lower at will.
 
However, while the animations for cancelling the sword strike and the "de-nocking" of an arrow play perfectly, the one for the blackjack does not - as the attached image demonstrates.
Steps To Reproduce1. Select Blackjack
2. Raise Blackjack in preparation for a strike (hold in this position)
3. Press button assigned to 'Parry' ('Z' by default)
4. Observe the jarring physical disconnection between the Blackjack object and the character's hand.
Additional InformationBecause it is not listed as performing this function in the Controls section, some people may not realise that one can actually cancel a prepared attack.

I would like to propose that the 'Parry' description be amended to include ("Aborts attack when weapon is raised") or something to that effect.

TagsNo tags attached.

Relationships

duplicate of 0002509 new blackjack idle 

Activities

Dunedain19

Dunedain19

16.02.2015 19:06

reporter  

nbohr1more

nbohr1more

15.12.2018 19:51

developer   ~0010936

Closed as duplicate of 2509

Issue History

Date Modified Username Field Change
16.02.2015 19:06 Dunedain19 New Issue
16.02.2015 19:06 Dunedain19 File Added: TDM Blackjack Animation Glitch.jpg
15.12.2018 19:49 nbohr1more Relationship added related to 0002509
15.12.2018 19:50 nbohr1more Relationship deleted related to 0002509
15.12.2018 19:51 nbohr1more Relationship added duplicate of 0002509
15.12.2018 19:51 nbohr1more Note Added: 0010936
15.12.2018 19:52 nbohr1more Assigned To => Springheel
15.12.2018 19:52 nbohr1more Status new => closed
15.12.2018 19:52 nbohr1more Resolution open => duplicate