View Issue Details

IDProjectCategoryView StatusLast Update
0004127The Dark ModGraphicspublic19.12.2018 19:39
ReporterSteveL Assigned Tostgatilov  
PrioritylowSeverityminorReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
Product VersionTDM 2.03 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004127: DrawSurf scissor rect invalid
DescriptionSome DrawSurfs in Talbot have a scissor rect of (32000, 32000, -63999, -63999).
Additional InformationDiscovered while working on shadows. Call stack:

> TheDarkMod.exe!RB_RenderDrawSurfChainWithFunction() Line 302 C / C++
     TheDarkMod.exe!RB_StencilShadowPass() Line 1467 C / C++
     TheDarkMod.exe!RB_ARB2_DrawInteractions() Line 307 C / C++
     TheDarkMod.exe!RB_STD_DrawView() Line 1959 C / C++
     TheDarkMod.exe!RB_DrawView() Line 906 C / C++

Causes OpenGL error. Observed in Talbot in front of the two statues right by the starting position.
TagsNo tags attached.

Relationships

related to 0004516 resolvedstgatilov Unstable visportals clipping 

Activities

duzenko

duzenko

05.03.2017 07:31

developer   ~0008759

Last edited: 05.03.2017 07:31

View 2 revisions

Observed that as well. As a temporary workaround to not provoke a glError added this check
if (drawSurf->scissorRect.x2 >= 0 && drawSurf->scissorRect.y2 >= 0)

stgatilov

stgatilov

07.05.2017 12:33

administrator   ~0008846

It might happen because of issue 4516, which is fixed now.
If you ever meet this behavior again, please report here.
nbohr1more

nbohr1more

19.12.2018 19:38

developer   ~0010982

No recent reports.

Issue History

Date Modified Username Field Change
31.03.2015 18:18 SteveL New Issue
31.03.2015 18:18 SteveL Status new => assigned
31.03.2015 18:18 SteveL Assigned To => SteveL
31.03.2015 18:32 SteveL Description Updated View Revisions
30.12.2015 15:25 SteveL Target Version TDM 2.04 =>
15.02.2017 04:37 grayman Assigned To SteveL =>
15.02.2017 04:37 grayman Status assigned => new
05.03.2017 07:31 duzenko Note Added: 0008759
05.03.2017 07:31 duzenko Note Edited: 0008759 View Revisions
07.05.2017 12:33 stgatilov Note Added: 0008846
15.09.2017 02:47 nbohr1more Relationship added related to 0004516
15.09.2017 02:47 nbohr1more Status new => feedback
19.12.2018 19:38 nbohr1more Note Added: 0010982
19.12.2018 19:39 nbohr1more Assigned To => stgatilov
19.12.2018 19:39 nbohr1more Status feedback => resolved
19.12.2018 19:39 nbohr1more Resolution open => unable to reproduce
19.12.2018 19:39 nbohr1more Fixed in Version => TDM 2.06
19.12.2018 19:39 nbohr1more Target Version => TDM 2.06