View Issue Details

IDProjectCategoryView StatusLast Update
0004148The Dark ModSound Systempublic16.10.2017 17:24
ReporterSteveL Assigned ToSteveL  
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionTDM 2.03 
Target VersionTDM 2.04Fixed in VersionTDM 2.04 
Summary0004148: Sounds popping in big maps
DescriptionTwo recent maps have excessive sound popping in certain locations. Semi-random, but up to 50% reproducible in certain spots.

When the sound pops on my system, sound from outside the game (other applications) is lost for a second or two.

Video
http://youtu.be/n-FTXhASUTQ
Additional Informationhttp://forums.thedarkmod.com/topic/17126-sound-popping/
TagsNo tags attached.

Relationships

related to 0002107 closed Click in crouch-running grass footstep 
related to 0002108 closed Squeak in crouch-running in shallow water footstep sound 

Activities

SteveL

SteveL

09.05.2015 08:39

developer   ~0007509

Last edited: 09.05.2015 08:50

View 2 revisions

The problem is in idSoundWorldLocal::ResolveOrigin, a recursive function that flows sound through portals and (1) tots up the volume contribution of different paths to the player, and (2) calculates the spatialized origin, the apparent origin of the sound, heard from the listener's position.

It needs an extra terminating condition up top: if the accumulated sound loss through a portal path is greater than the emitter volume, quit instead of returning a set of numbers that will resolve to 0 volume.

The problem arises later in the same function when it merges together results from different portal chains. If there's more than one chain whose length is within the sound's max distance, but *all* chains found resolve to 0 volume because of sound loss on the portals, then we get a division by zero in the spatialized origin calculation, which eventually ends up being fed into to the sound card as a channel volume.

SteveL

SteveL

09.05.2015 12:26

developer   ~0007510

At rev 6494

/trunk/sound/snd_world.cpp

Issue History

Date Modified Username Field Change
09.05.2015 06:36 SteveL New Issue
09.05.2015 06:36 SteveL Status new => assigned
09.05.2015 06:36 SteveL Assigned To => SteveL
09.05.2015 08:39 SteveL Note Added: 0007509
09.05.2015 08:50 SteveL Note Edited: 0007509 View Revisions
09.05.2015 12:26 SteveL Note Added: 0007510
09.05.2015 12:34 SteveL Status assigned => resolved
09.05.2015 12:34 SteveL Fixed in Version => TDM 2.04
09.05.2015 12:34 SteveL Resolution open => fixed
16.10.2017 17:21 nbohr1more Relationship added related to 0002107
16.10.2017 17:24 nbohr1more Relationship added related to 0002108