View Issue Details

IDProjectCategoryView StatusLast Update
0004155The Dark ModModelspublic17.08.2017 13:56
Reportergrayman Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionTDM 2.04 
Target VersionTDM 2.06 
Summary0004155: Wish List for Architectural Modules
DescriptionThis issue is to track desired architectural modules to add to the new interior and exterior sets.

1. http://forums.thedarkmod.com/topic/17099-st-lucia-campaign-final-mission-phase-1/page-5#entry371981

2. http://forums.thedarkmod.com/topic/17099-st-lucia-campaign-final-mission-phase-1/page-5#entry372011
TagsNo tags attached.

Activities

grayman

grayman

25.05.2015 00:28

administrator   ~0007532

The default stairs modules use two different textures on the posts:

textures/darkmod/wood/boards/wood_brown_dull01

textures/darkmod/wood/panels/panel_carved_rectangles_01_dullbrown

The latter should be replaced with the former.

Also, the lower paneling on the staircase uses the latter texture, and the mixture of dull brown wood and red wood looks odd.
grayman

grayman

29.05.2015 02:01

administrator   ~0007550

Please make an interior arch for the timber set.
Springheel

Springheel

29.05.2015 13:24

administrator   ~0007551

* The interior_mansion01 archway could use more polys

* fix the edge of the railway so it can be visible
grayman

grayman

01.06.2015 03:05

administrator   ~0007553

Getting this warning:

WARNING:ConvertLWOToModelSurfaces: model 'models/darkmod/architecture/modules/exteriors/ext_stone01/ext_stone01_window01.lwo' has too many verts for a poly! Make sure you triplet it down
grayman

grayman

03.06.2015 11:57

administrator   ~0007554

Last edited: 03.06.2015 11:58

View 2 revisions

The brick-skinned model ext_timber01_window01_covered.lwo has slanted bricks on either side of the window. Doesn't look right. The bricklayer would have been drawn and quartered. :)

See attached pic.

Other timber window modules should be checked for this also.

Springheel

Springheel

27.06.2015 11:39

administrator   ~0007603

Last edited: 03.08.2015 13:01

View 2 revisions

The short and tall fence pillars have some uv stretching that needs to be fixed.

edit: done

grayman

grayman

02.07.2015 02:55

administrator   ~0007608

The exterior timber window01 and window02 modules need matching interior modules.

Atm, the closest we can get is exterior window03 and interior *set01_window*, but they don't line up (per second link in "Description" above).
Springheel

Springheel

03.08.2015 13:02

administrator   ~0007698

The pieces with angled bits along the wall/floor need to be surrounded with clip. Otherwise when the player falls on them, he is projected outwards. Also makes creeping along the wall awkward. This applies to most of the mansion01 pieces as well as the bookshelves.
grayman

grayman

14.08.2015 15:24

administrator   ~0007714

There's a gap between the columns and the lower vertical walls of models/darkmod/architecture/modules/exteriors/ext_stone02_plain/ext_stone02_arch01.lwo.

You can see the gap (pink) in the second attached picture.
grayman

grayman

08.01.2016 19:31

administrator  

arch.jpg (797,786 bytes)
grayman

grayman

08.01.2016 19:32

administrator   ~0008008

models/darkmod/architecture/modules/interior_mansion01/mansion01_arch01_128.lwo

has a gap at the base. See attached arch.jpg.
grayman

grayman

15.01.2016 19:19

administrator   ~0008027

models/darkmod/architecture/modules/interior_mansion01/mansion01_wainscoting01.lwo

uses a noshadow texture for the main panel, but is missing a shadow texture there, so light spills through the main panel.
Springheel

Springheel

24.01.2016 16:04

administrator   ~0008030

models/darkmod/junk/wood_debris02.lwo has some missing polys
grayman

grayman

26.02.2016 15:38

administrator  

small_frame.jpg (202,766 bytes)   
small_frame.jpg (202,766 bytes)   
grayman

grayman

26.02.2016 15:39

administrator   ~0008046

Last edited: 08.03.2016 22:03

View 3 revisions

Shadow problem with models/darkmod/architecture/modules/interior_mansion01/frame02_empty_small.lwo

See small_frame.jpg (attached). This is looking up at a ceiling that has the frames pasted to it.

Edit: I found out what the real issue is. Each section of the frame has two depths: an inner and an outer. By aligning the outer against the wall behind it, the inner doesn't align with the wall, and it leaves a gap. A light shining from outside the frame shines through the gap, giving the result.

By pushing the frame farther into the wall so that the inner depth touches the wall, the shadow problem goes away. Of course, the frame now has a smaller width and height, because part of it is pushed inside the wall.

The same problem appears in both the small and large frames.

grayman

grayman

19.03.2016 14:49

administrator  

window.jpg (154,465 bytes)   
window.jpg (154,465 bytes)   
grayman

grayman

19.03.2016 14:50

administrator   ~0008056

models/darkmod/architecture/modules/interior_mansion01/mansion01_window01.lwo has some missing polys.

You can see the holes when looking down on the window. In the attached picture (window.jpg) the pink belongs to the caulked wall behind the window.
grayman

grayman

24.04.2016 20:19

administrator  

eaves.jpg (140,571 bytes)   
eaves.jpg (140,571 bytes)   
grayman

grayman

24.04.2016 20:21

administrator   ~0008118

models/darkmod/architecture/modules/exteriors/ext_timber01/ext_timber01_combo_256x256_top01.lwo

is missing roofing texture at each corner of the roof.

See "eaves.jpg" (attached).

The texture is missing at both front roof corners.
grayman

grayman

07.05.2016 01:53

administrator   ~0008140

Given your departure, what happens to the unfinished requests in this tracker issue?
Springheel

Springheel

03.07.2016 03:20

administrator   ~0008236

Last edited: 19.07.2016 19:37

View 5 revisions

exterior_timber_window01 UV issue -- fixed.

WARNING:ConvertLWOToModelSurfaces: model 'models/darkmod/architecture/modules/exteriors/ext_stone01/ext_stone01_window01.lwo' has too many verts for a poly! Make sure you triplet it down -- fixed

There's a gap between the columns and the lower vertical walls of models/darkmod/architecture/modules/exteriors/ext_stone02_plain/ext_stone02_arch01.lwo. -- fixed

models/darkmod/architecture/modules/interior_mansion01/mansion01_arch01_128.lwo -- fixed

uses a noshadow texture for the main panel, but is missing a shadow texture there, so light spills through the main panel. --fixed

Springheel

Springheel

03.07.2016 13:14

administrator   ~0008237

"The default stairs modules use two different textures on the posts:
textures/darkmod/wood/boards/wood_brown_dull01
textures/darkmod/wood/panels/panel_carved_rectangles_01_dullbrown
The latter should be replaced with the former."

I don't understand the issue here. The "panel_carved_rectangles_01_dullbrown" texture didn't have an editor version, but should look fine in game.
grayman

grayman

03.07.2016 15:20

administrator   ~0008238

The issue is that the model looks odd in DR with the same post having two different side textures on it. Might cause issues for people creating their own skins (or at least make it a bit more work).

Since they create the same image in the game, I guess this request can be dropped.
Springheel

Springheel

03.07.2016 19:45

administrator   ~0008239

I've added an editor_image so it won't look confusing in DR anymore.
grayman

grayman

03.07.2016 20:01

administrator   ~0008240

Ok, thanks.
Springheel

Springheel

19.07.2016 19:43

administrator   ~0008242

Last edited: 07.08.2016 23:39

View 4 revisions

models/darkmod/junk/wood_debris02.lwo has some missing polys -- fixed

Shadow problem with models/darkmod/architecture/modules/interior_mansion01/frame02_empty_small.lwo -- fixed

models/darkmod/architecture/modules/interior_mansion01/mansion01_window01.lwo has some missing polys. -- fixed

models/darkmod/architecture/modules/exteriors/ext_timber01/ext_timber01_combo_256x256_top01.lwo is missing roofing texture at each corner of the roof. -- fixed

Issue History

Date Modified Username Field Change
24.05.2015 20:06 grayman New Issue
24.05.2015 20:06 grayman Status new => assigned
24.05.2015 20:06 grayman Assigned To => Springheel
25.05.2015 00:28 grayman Note Added: 0007532
29.05.2015 02:01 grayman Note Added: 0007550
29.05.2015 13:24 Springheel Note Added: 0007551
01.06.2015 03:05 grayman Note Added: 0007553
03.06.2015 11:56 grayman File Added: module.jpg
03.06.2015 11:57 grayman Note Added: 0007554
03.06.2015 11:58 grayman Note Edited: 0007554 View Revisions
27.06.2015 11:39 Springheel Note Added: 0007603
02.07.2015 02:55 grayman Note Added: 0007608
03.08.2015 13:01 Springheel Note Edited: 0007603 View Revisions
03.08.2015 13:02 Springheel Note Added: 0007698
14.08.2015 15:23 grayman File Added: ext_stone02_arch01.jpg
14.08.2015 15:24 grayman Note Added: 0007714
03.01.2016 18:16 grayman Target Version TDM 2.04 => TDM 2.05
08.01.2016 19:31 grayman File Added: arch.jpg
08.01.2016 19:32 grayman Note Added: 0008008
15.01.2016 19:19 grayman Note Added: 0008027
24.01.2016 16:04 Springheel Note Added: 0008030
26.02.2016 15:38 grayman File Added: small_frame.jpg
26.02.2016 15:39 grayman Note Added: 0008046
08.03.2016 21:55 grayman Note Edited: 0008046 View Revisions
08.03.2016 22:03 grayman Note Edited: 0008046 View Revisions
19.03.2016 14:49 grayman File Added: window.jpg
19.03.2016 14:50 grayman Note Added: 0008056
24.04.2016 20:19 grayman File Added: eaves.jpg
24.04.2016 20:21 grayman Note Added: 0008118
07.05.2016 01:53 grayman Note Added: 0008140
03.07.2016 03:20 Springheel Note Added: 0008236
03.07.2016 13:14 Springheel Note Added: 0008237
03.07.2016 13:18 Springheel File Deleted: module.jpg
03.07.2016 13:19 Springheel Note Edited: 0008236 View Revisions
03.07.2016 13:25 Springheel Note Edited: 0008236 View Revisions
03.07.2016 13:25 Springheel File Deleted: ext_stone02_arch01.jpg
03.07.2016 15:20 grayman Note Added: 0008238
03.07.2016 19:45 Springheel Note Added: 0008239
03.07.2016 19:55 Springheel Note Edited: 0008236 View Revisions
03.07.2016 20:01 grayman Note Added: 0008240
19.07.2016 19:37 Springheel Note Edited: 0008236 View Revisions
19.07.2016 19:43 Springheel Note Added: 0008242
22.07.2016 17:43 Springheel Note Edited: 0008242 View Revisions
22.07.2016 18:01 Springheel Note Edited: 0008242 View Revisions
07.08.2016 23:39 Springheel Note Edited: 0008242 View Revisions
25.11.2016 13:57 grayman Target Version TDM 2.05 => TDM 2.06
17.08.2017 13:56 Springheel Status assigned => resolved
17.08.2017 13:56 Springheel Resolution open => fixed