View Issue Details

IDProjectCategoryView StatusLast Update
0000421DarkRadiantGeneralpublic11.12.2007 16:06
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.4 
Target Version0.9.5Fixed in Version0.9.5 
Summary0000421: Crash on shutdown after using S/R editor
DescriptionNote this is NOT the crash mentioned here (although I suppose it could be related): http://modetwo.net/darkmod/index.php?showtopic=6817&hl=

I was trying to narrow this down to minimal steps, but when I do it becomes much less reliable. So instead, here are 100% reliable steps (on my system), although most of them are probably non-specific to the crash itself:

-Start DR
-Open srtest.map found here: http://208.49.149.118/thedarkmod/temp/srtest.rar
-Select the third button on the right
-Open the S/R editor
-Click Responses tab
-Click the second entry, the disabled Frob Response
-D-click the Deactivate Response response effect
-Change the Effect to Activate Response*
-Hit Apply
-Hit OK
-Close DR by hitting the X in upper right corner (don't save changes)

At this point, I get a fully reproducable crash.

*Note that I get those weird, full screen height, partially empty, popup listboxes we talked about long ago ( http://img66.imageshack.us/img66/8397/drcrash1ys2.jpg ), and if I don't change the Response Effect (which requires this listbox), I don't seem to get the crash. So I guess it could be more than just an innocuous, weird listbox at work here...

I'm not sure how helpful the end of the log is:
...
[shaders] Loaded texture: textures/darkmod/sfx/greenglass
  RenderablePicoSurface: using shader textures/common/collision
map load timer: 4.03 second(s) elapsed
--- LoadMapFile ---
D:/games/Doom3/darkmod/maps/srtest.map
10 brushes
0 patches
18 entities
editStimResponse
map path is not fully qualified: "target_set_frobable_1"
map path is not fully qualified: "atdm_mover_button_3"
map path is not fully qualified: "atdm_mover_button_4"
map path is not fully qualified: "atdm_mover_button_5"
Open file D:/games/Doom3/darkmod/ for read...failure

[end of log]
TagsNo tags attached.

Activities

greebo

greebo

09.11.2007 11:19

administrator   ~0000848

I guess one of the main problems is the use of shared_ptrs across modules. Once the modules are unloaded the shared_ptrs held in the main binary tend to go crazy. One example of this was the RadiantEventListener list which held shared_ptrs of objects instantiated in modules.

Should be fixed now.
SneaksieDave

SneaksieDave

09.11.2007 18:56

developer   ~0000855

Hm, I still get the crash consistently. The log looks the same, as does the funky weird popup listbox. I remember this listbox problem before but don't recall what the outcome was. Could that be it? Something else I want to mention: when I'm shutting down, the cam and ortho view remain on screen, when the error message comes up. So at this point, the rest of the UI has disappeared except for those two windows. Don't know if that's relevant. Maybe the S/R dialog or that list or whatever isn't destroyed?

Let me know if there's more I can assist with. I'd be inclined to say this isn't a terribly serious crash, since it occurs at shutdown, but it's possible that it could be related to the other S/R crash I got yesterday, I guess.
greebo

greebo

09.11.2007 22:13

administrator   ~0000858

I can't see the crash in Visual C++ unfortunately, but I'll try to reproduce it using the MinGW compiler and/or Linux gcc.
greebo

greebo

09.11.2007 23:13

administrator   ~0000859

Gah, confirmed! The crash is still there (again?). DR crashes at the same position as before, I swear I fixed that already...
greebo

greebo

10.11.2007 10:49

administrator   ~0000860

Fixed another time, hopefully for good! New snapshot build is up on the website soon.
SneaksieDave

SneaksieDave

11.12.2007 16:06

developer   ~0000920

Tried it a handful of times and checked the log; no more occurrences.

Issue History

Date Modified Username Field Change
08.11.2007 23:54 SneaksieDave New Issue
09.11.2007 08:27 greebo Status new => acknowledged
09.11.2007 08:28 greebo Status acknowledged => assigned
09.11.2007 08:28 greebo Assigned To => greebo
09.11.2007 11:19 greebo Note Added: 0000848
09.11.2007 11:19 greebo Status assigned => resolved
09.11.2007 11:19 greebo Fixed in Version => latest SVN
09.11.2007 11:19 greebo Resolution open => fixed
09.11.2007 11:19 greebo Build => 2512
09.11.2007 11:19 greebo Target Version => 0.9.5
09.11.2007 11:47 greebo Fixed in Version => 0.9.5
09.11.2007 18:56 SneaksieDave Note Added: 0000855
09.11.2007 18:56 SneaksieDave Status resolved => feedback
09.11.2007 18:56 SneaksieDave Resolution fixed => reopened
09.11.2007 22:13 greebo Note Added: 0000858
09.11.2007 22:13 greebo Status feedback => assigned
09.11.2007 23:13 greebo Note Added: 0000859
10.11.2007 10:49 greebo Note Added: 0000860
10.11.2007 10:49 greebo Status assigned => resolved
10.11.2007 10:49 greebo Resolution reopened => fixed
11.12.2007 16:06 SneaksieDave Note Added: 0000920
11.12.2007 16:06 SneaksieDave Status resolved => closed