View Issue Details

IDProjectCategoryView StatusLast Update
0004262The Dark ModCodingpublic10.10.2017 02:35
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.03 
Target VersionTDM 2.04Fixed in VersionTDM 2.04 
Summary0004262: Locked doors with button controllers can be opened by illegal keys
DescriptionCheck the design of locked doors with button controllers. It appears that a key other than a "used_byN" key can unlock the controller after several attempts.
TagsNo tags attached.

Relationships

related to 0001189 closed Normal frob action from key + unrelated or unlocked door 

Activities

grayman

grayman

04.01.2016 02:26

administrator   ~0007963

Turns out the controllers can't be lock-picked either.

Fix that.
grayman

grayman

04.01.2016 14:00

administrator   ~0007964

Abort processing of REPEAT and RELEASE states once a button controller fails to unlock with an illegal key in the PRESSED state.

Add the “wrong key” sound to the controller.

rev. 6565:

Player.cpp
BinaryFrobMover.cpp
FrobDoor.cpp

Issue History

Date Modified Username Field Change
16.12.2015 18:29 grayman New Issue
16.12.2015 18:29 grayman Status new => assigned
16.12.2015 18:29 grayman Assigned To => grayman
04.01.2016 02:26 grayman Note Added: 0007963
04.01.2016 14:00 grayman Note Added: 0007964
04.01.2016 14:00 grayman Status assigned => resolved
04.01.2016 14:00 grayman Resolution open => fixed
04.01.2016 14:00 grayman Fixed in Version => TDM 2.04
10.10.2017 02:35 nbohr1more Relationship added related to 0001189