View Issue Details

IDProjectCategoryView StatusLast Update
0004276DarkRadiantDesign/Codingpublic25.09.2016 19:44
Reportergrayman Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.3 
Target Version2.0.4Fixed in Version2.0.4 
Summary0004276: Path connections disappear when one endpoint is not visible
DescriptionWith 2.0.4 pre 1, if I have path node A targeted to path node B, both are in a visible layer, and A is visible on the screen and B isn't, DR doesn't paint the target line from A to B. Ditto if B is on the screen and A isn't.

This makes it difficult to get a general sense of where an AI is traveling unless his entire path is visible.

This is new behavior.
Additional InformationOn the other hand, if AI C targets path node D, and one or the other is not in the view, the connection line still gets painted.

Connection lines should only get dropped when an object disappears due to being in a hidden layer.
TagsNo tags attached.

Activities

greebo

greebo

07.01.2016 13:24

administrator   ~0007986

This is due to the Octree filtering out scene nodes. If a node is not rendered, its target keys are not drawn either. A possible workaround would be to submit the target lines as separate entities (either to the scene or to the rendering system). One has to take care not to use the GlobalRenderSystem() but the one attached to the owning entity node.

user81

24.04.2016 13:04

  ~0008114

The issue I think isnt that the path_nodes aren't being render but that the target lines between them aren't. For example a given path_wait or path_corner can be just off-screen and he target line is still drawn, but then you move the view so the path_node goes further off-screen its at that point the target-line disappears. And this dosent apply to all path_nudes that are off screen either.

The issue with the target lines disappearing is that its almost impossible to follow a given path, as you have to stop move the camera around contently to see where the paths are going - vastly slowing down workflow.
greebo

greebo

01.05.2016 11:42

administrator   ~0008127

Fixed in 39a494e1501a4a625280186947c48f679ebba57a
grayman

grayman

25.09.2016 18:27

administrator   ~0008348

tested

user81

25.09.2016 19:44

  ~0008353

Sweet

Issue History

Date Modified Username Field Change
07.01.2016 13:09 grayman New Issue
07.01.2016 13:24 greebo Note Added: 0007986
07.01.2016 13:25 greebo Status new => confirmed
24.04.2016 13:04 user81 Note Added: 0008114
01.05.2016 10:29 greebo Assigned To => greebo
01.05.2016 10:29 greebo Status confirmed => assigned
01.05.2016 10:29 greebo Target Version => 2.0.4
01.05.2016 11:42 greebo Note Added: 0008127
01.05.2016 11:42 greebo Status assigned => resolved
01.05.2016 11:42 greebo Fixed in Version => 2.0.4
01.05.2016 11:42 greebo Resolution open => fixed
25.09.2016 18:27 grayman Note Added: 0008348
25.09.2016 18:27 grayman Status resolved => closed
25.09.2016 19:44 user81 Note Added: 0008353