View Issue Details

IDProjectCategoryView StatusLast Update
0004303The Dark ModDesign/Codingpublic15.07.2021 23:13
ReporterVanishedOne Assigned ToSteveL  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionduplicate 
Product VersionTDM 2.03 
Target VersionTDM 2.04Fixed in VersionTDM 2.04 
Summary0004303: hide_distance not hiding entities (without an LOD model set)
DescriptionAccording to http://wiki.thedarkmod.com/index.php?title=Performance:_Essential_Must-Knows#Hide_Distance the minimum to hide an entity at a minimum distance should be positive values for "hide_distance" and "dist_check_period". However, this isn't the case: see http://wiki.thedarkmod.com/index.php?title=Talk:LOD and the attached map.

Either the implementation is bugged or the first wiki entry is wrong. Certainly there's no obvious (to a mapper) reason why that doesn't work.
TagsNo tags attached.

Relationships

duplicate of 0003912 resolvedSteveL LOD problems with custom "model" spawnarg 
related to 0005668 resolvedduzenko hide_distance won't work for lights 

Activities

VanishedOne

VanishedOne

10.04.2016 13:16

reporter  

lod.map (9,205 bytes)
VanishedOne

VanishedOne

10.04.2016 15:13

reporter   ~0008074

Also, I'm now trying to set up an entity that does have an LOD stage, and finding that it won't change to its lowpoly version unless hide_distance is also set.
SteveL

SteveL

11.04.2016 19:12

reporter   ~0008088

I'm tentatively adding this to the 2.04 road map. We tweaked this mechanism in 2.04 so the behaviour of this spawnarg might already be different. None of our changes should have broken existing maps of course. This report needs investigating in 2.04.
SteveL

SteveL

11.06.2016 12:49

reporter   ~0008208

This turns out to be something I broke in 2.03 and already fixed for 2.04 --> 0003912

Confirmed that the test map is broken in 2.03 but works in 2.04.

Issue History

Date Modified Username Field Change
10.04.2016 13:16 VanishedOne New Issue
10.04.2016 13:16 VanishedOne File Added: lod.map
10.04.2016 15:13 VanishedOne Note Added: 0008074
11.04.2016 19:12 SteveL Note Added: 0008088
11.04.2016 19:12 SteveL Assigned To => SteveL
11.04.2016 19:12 SteveL Status new => assigned
11.04.2016 19:12 SteveL Target Version => TDM 2.04
11.06.2016 12:49 SteveL Note Added: 0008208
11.06.2016 12:49 SteveL Relationship added duplicate of 0003912
11.06.2016 12:49 SteveL Status assigned => closed
11.06.2016 12:49 SteveL Resolution open => duplicate
11.06.2016 12:49 SteveL Fixed in Version => TDM 2.04
15.07.2021 23:13 nbohr1more Relationship added related to 0005668