View Issue Details

IDProjectCategoryView StatusLast Update
0004313DarkRadiantGUIpublic29.03.2017 18:29
Reporteruser81Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilitysometimes
Status closedResolutionfixed 
Product Version2.0.4 
Target Version2.1.0Fixed in Version2.1.0 
Summary0004313: Dark spots/areas on patches when exporting to ASE
DescriptionSometimes when working ong patches I would get a dark patch where it looks like a normal was borked. But then I started seeing it in DR and now recognised its been a DR issue all this time.
Steps To ReproduceCant as I dont know what's causing it, all I know is DR is introducing these anomalies into the patches, and these are then directly viewable in-game
Additional InformationThread where I asked what was causing it but nobody knew -

http://forums.thedarkmod.com/topic/15026-dr-ase-blend-exporter/page-3?hl=%2Bblend+%2Bpatch+%2Bbikerdude#entry320863

And the youtube video demonstrating how to reproduce -

https://youtu.be/emhNb3CkOCU
TagsNo tags attached.

Relationships

related to 0004321 closedgreebo Patch tesselation code produces strange normals on some patches 

Activities

greebo

greebo

05.05.2016 05:29

administrator   ~0008135

Can you send me a small map or prefab with that patch you've shown in the video, please?

user81

05.05.2016 07:07

  ~0008136

Done, see attached.
greebo

greebo

06.05.2016 14:50

administrator   ~0008138

Ok, I can see the shading on those patches too. It happens with pretty much any patch that is higher than 3x3 AND has fixed subdivisions enabled (higher than 1x1).

What I can't reproduce is to get the shading visible in-game. Can you confirm these steps:

- Create Patch 5x3 and give it a caulk texture
- Set fixed subdivisions to 2x1
- Save the map
- Reload the map, it should show the shadings

- Make a room, bright ambient and player start and dmap that stuff to get it in-game
- Can you see the shadings?
hypov8

hypov8

11.05.2016 06:59

reporter   ~0008144

Last edited: 11.05.2016 07:01

View 2 revisions

the link refers to .ase exports. is this when you see the issue?
my guess is the abnormal face/vertex normal in the editor are written to the .ase

example of exported .ase

*MESH_FACENORMAL 5 0.0000 0.0000 1324.0000
    *MESH_VERTEXNORMAL 3 0.0000 0.0000 1324.0000


i would guess these are ment to be -1 to +1 rotatation values

user81

17.05.2016 17:54

  ~0008149

So Hypov was spot on, the issue only effects exported .ASE mdoels made from patches.

- https://youtu.be/QKTkwc1IYTI
greebo

greebo

21.05.2016 09:27

administrator   ~0008155

Ok, so the issue can be dampened a bit by renormalising the normals during ASE export, but the root cause seems to be that DR's patch tesselation code is not working the same way as the code in the engine. Fixing the latter is not something for the 2.0.4 release, this it too large of a change.

user81

21.05.2016 09:50

  ~0008157

Fair enough fella.
greebo

greebo

11.06.2016 07:35

administrator   ~0008206

Future ASE exports shouldn't exhibit this behaviour anymore.

user81

11.06.2016 08:31

  ~0008207

Nice one, that is very much appreciated.

Issue History

Date Modified Username Field Change
02.05.2016 18:52 user81 New Issue
02.05.2016 18:52 user81 Status new => assigned
02.05.2016 18:52 user81 Assigned To => greebo
02.05.2016 19:07 user81 Additional Information Updated View Revisions
05.05.2016 05:29 greebo Note Added: 0008135
05.05.2016 05:29 greebo Assigned To greebo =>
05.05.2016 05:29 greebo Status assigned => feedback
05.05.2016 07:06 user81 File Added: lute.zip
05.05.2016 07:07 user81 Note Added: 0008136
05.05.2016 07:07 user81 Status feedback => new
06.05.2016 14:50 greebo Note Added: 0008138
06.05.2016 14:50 greebo Status new => feedback
11.05.2016 06:59 hypov8 Note Added: 0008144
11.05.2016 07:01 hypov8 Note Edited: 0008144 View Revisions
17.05.2016 17:54 user81 Note Added: 0008149
17.05.2016 17:54 user81 Status feedback => new
21.05.2016 09:27 greebo Note Added: 0008155
21.05.2016 09:28 greebo Target Version 2.0.4 =>
21.05.2016 09:28 greebo Summary Dark spots/area's on patches => Dark spots/areas on patches when exporting to ASE
21.05.2016 09:34 greebo Relationship added related to 0004321
21.05.2016 09:34 greebo Status new => confirmed
21.05.2016 09:34 greebo File Deleted: lute.zip
21.05.2016 09:50 user81 Note Added: 0008157
11.06.2016 07:35 greebo Assigned To => greebo
11.06.2016 07:35 greebo Status confirmed => assigned
11.06.2016 07:35 greebo Target Version => 2.1.0
11.06.2016 07:35 greebo Note Added: 0008206
11.06.2016 07:35 greebo Status assigned => resolved
11.06.2016 07:35 greebo Fixed in Version => 2.1.0
11.06.2016 07:35 greebo Resolution open => fixed
11.06.2016 08:31 user81 Note Added: 0008207
29.03.2017 18:29 greebo Status resolved => closed