View Issue Details

IDProjectCategoryView StatusLast Update
0004323DarkRadiantGUIpublic27.05.2016 21:19
Reporteruser81Assigned Touser81 
PrioritynormalSeveritynormalReproducibilityhave not tried
Status closedResolutionfixed 
PlatformPC, Windows, x64OSWin 7/8OS VersionSp2/8.1
Product Version2.0.4 
Fixed in Version2.0.4 
Summary0004323: Windows focus, popup/alert when selecting function off main window
DescriptionThis was fixed in pre6, but is now happening again in pre7/8 -
 
If you have the main window selected and hit S or R to open up the child windows, DR or windows is alerting me. As in its complaining that I dont have the child window selected/opened at the time when trying to perform a function - hence the beep/alert.
TagsNo tags attached.

Activities

greebo

greebo

23.05.2016 17:43

administrator   ~0008165

This is confusing, as I didn't change anything with regard to the areas you describe in between pre6 and pre8.

I just tried to repro this, but I failed to do so. When the main window or even the layers dialog is focused the "S" shortcut to toggle the surface inspector works fine as expected.

Are you absolutely sure that this is something specific to pre8, and it didn't happen in pre7? You can run both of them side-by-side (when launching the portable DR versions) and check if they function differently.

If it's reproducible for you, maybe a video would help?

user81

23.05.2016 18:11

  ~0008168

It happened in Pre7 and now 8 - I will make a video of it :-)

user81

26.05.2016 20:59

  ~0008175

Sorry this took so long to do -

https://www.youtube.com/watch?v=c7J7tSk3VtU&
grayman

grayman

26.05.2016 21:21

administrator   ~0008176

I have the same problem. I've been turning my speakers off while editing.
greebo

greebo

27.05.2016 05:08

administrator   ~0008178

I'll see what I can do.
greebo

greebo

27.05.2016 05:10

administrator   ~0008179

I can confirm that behaviour, it's definitely bound to having the focus set on some buttons in the GUI. It doesn't happen when you left-click in one of the render views.
greebo

greebo

27.05.2016 11:36

administrator   ~0008181

Last edited: 27.05.2016 11:37

View 2 revisions

I'm afraid that there's no point in any of "my" code that I can touch to fix this. I've tried to signal back to Windows that the key event has been processed, and I've tried to signal "key event ignored", but the sound just keeps playing. It seems to be default Windows behaviour to play that sound when you focus a button and press a key that has no function in that dialog.

You can easily see this by opening Windows Explorer and RMB any file to show its properties. Hit the "G" key which shouldn't do anything in the properties and you'll hear the same sound.

For me I've only found the workaround to unmap the "Default Beep" sound in the Control Panel > Sound dialog.

user81

27.05.2016 12:33

  ~0008183

Last edited: 27.05.2016 21:19

View 2 revisions

Fair enough fella, and removing the windows sound scheme is good enough for me, as I normally have that set to no sounds etc.

grayman

grayman

27.05.2016 20:26

administrator   ~0008186

I turned off the default beep and all is well now.

Thanks.

user81

27.05.2016 21:19

  ~0008189

that can be considered closed.

Issue History

Date Modified Username Field Change
23.05.2016 11:41 user81 New Issue
23.05.2016 11:41 user81 Status new => assigned
23.05.2016 11:41 user81 Assigned To => greebo
23.05.2016 17:43 greebo Note Added: 0008165
23.05.2016 17:45 greebo Assigned To greebo =>
23.05.2016 17:45 greebo Status assigned => feedback
23.05.2016 18:11 user81 Note Added: 0008168
23.05.2016 18:11 user81 Status feedback => new
26.05.2016 05:16 greebo Target Version 2.0.4 =>
26.05.2016 20:59 user81 Note Added: 0008175
26.05.2016 21:21 grayman Note Added: 0008176
27.05.2016 05:08 greebo Note Added: 0008178
27.05.2016 05:08 greebo Status new => acknowledged
27.05.2016 05:10 greebo Note Added: 0008179
27.05.2016 05:10 greebo Status acknowledged => confirmed
27.05.2016 11:36 greebo Note Added: 0008181
27.05.2016 11:37 greebo Note Edited: 0008181 View Revisions
27.05.2016 12:33 user81 Note Added: 0008183
27.05.2016 20:26 grayman Note Added: 0008186
27.05.2016 21:19 user81 Note Edited: 0008183 View Revisions
27.05.2016 21:19 user81 Note Added: 0008189
27.05.2016 21:19 user81 Status confirmed => closed
27.05.2016 21:19 user81 Assigned To => user81
27.05.2016 21:19 user81 Resolution open => fixed
27.05.2016 21:19 user81 Fixed in Version => 2.0.4