View Issue Details

IDProjectCategoryView StatusLast Update
0004366DarkRadiantCompilation/Buildpublic07.07.2017 18:51
Reportermhoes Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSLinuxOS VersionFedora 24
Product Version2.0.4 
Target Version2.2.0Fixed in Version2.2.0 
Summary0004366: Linux './configure' script WARNING
DescriptionWhen running './configure' on Linux, using the latest git revision of darkradiant, the following warning is produced :

checking for the toolset name used by Boost for g++...
configure: WARNING: could not figure out which toolset name to use for g++

This appears to be the same bug as reported in 0003183.
Steps To Reproducerun './autogen.sh'
run './configure --enable-debug --enable-darkmod-plugins'
TagsNo tags attached.

Relationships

duplicate of 0003183 closed Linux './configure' script WARNING 

Activities

greebo

greebo

27.12.2016 07:36

administrator   ~0008641

Last edited: 27.12.2016 07:36

View 2 revisions

Which g++ version are you running on your system?

Does the warning go away if you take the boost.m4 file from https://raw.githubusercontent.com/tsuna/boost.m4/master/build-aux/boost.m4 and put it in the m4 folder in your DarkRadiant clone? You'll need to run ./autogen.sh and then './configure --enable-debug --enable-darkmod-plugins' again for the macro change to take effect.

mhoes

mhoes

27.12.2016 11:22

reporter   ~0008645

I am running gcc version 6.2.1 on Fedora 25. The message goes away after copying the boost.m4 file you linked to, to my m4 directory.
greebo

greebo

27.12.2016 16:24

administrator   ~0008649

Ok, thanks for testing, I'll go ahead and update the boost m4 macros.
greebo

greebo

27.12.2016 16:28

administrator   ~0008650

Updated the boost.m4 file in 462a95a19a8e06ad0bf1f4f95bf659e6bcd68dce. The next time the ./autogen.sh script is run the warning should be gone.
greebo

greebo

27.12.2016 18:45

administrator   ~0008658

Last edited: 27.12.2016 18:45

View 2 revisions

Out of curiosity, are you able to run DarkRadiant in Fedora 25? I tried and it segfaulted on me.

wxWidgets seems to have a serious problem with Wayland, since the wxGLCanvas code is still referring to X11 calls (http://trac.wxwidgets.org/ticket/17702).

mhoes

mhoes

27.12.2016 19:06

reporter   ~0008661

i honestly haven't tried ;) but, yes, since fedora 25 seems to be the 1st major linux distro that has wayland as default, it seems like a good test case to try this on. but for this one, i don't particularly feel like being a crash test dummy on this particular case. ;) thanks again though, for solving the issue i reported !

Issue History

Date Modified Username Field Change
25.08.2016 17:38 mhoes New Issue
28.08.2016 05:05 greebo Relationship added duplicate of 0003183
28.08.2016 05:05 greebo Status new => acknowledged
27.12.2016 07:36 greebo Note Added: 0008641
27.12.2016 07:36 greebo Status acknowledged => feedback
27.12.2016 07:36 greebo Note Edited: 0008641 View Revisions
27.12.2016 11:22 mhoes Note Added: 0008645
27.12.2016 11:22 mhoes Status feedback => new
27.12.2016 16:24 greebo Note Added: 0008649
27.12.2016 16:28 greebo Note Added: 0008650
27.12.2016 16:28 greebo Status new => resolved
27.12.2016 16:28 greebo Fixed in Version => 2.2.0
27.12.2016 16:28 greebo Resolution open => fixed
27.12.2016 16:28 greebo Assigned To => greebo
27.12.2016 16:28 greebo Target Version => 2.2.0
27.12.2016 18:45 greebo Note Added: 0008658
27.12.2016 18:45 greebo Note Edited: 0008658 View Revisions
27.12.2016 19:06 mhoes Note Added: 0008661
07.07.2017 18:51 greebo Status resolved => closed