View Issue Details

IDProjectCategoryView StatusLast Update
0004373DarkRadiantGeneralpublic30.12.2019 07:46
Reportergrayman Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.4 
Target Version2.1.0Fixed in Version2.1.0 
Summary0004373: Connecting lines are created in Default layer
DescriptionIf I create a switch and target it to an object (i.e. a light), and my Default layer is hidden, the connecting line from the switch to the object isn't drawn.
 
If I then make the Default layer visible, the connecting line appears.
 
Make the Default layer hidden again, and the connecting line disappears.
Steps To ReproduceThe attached map has a light on one column and a switch on the other.

The light and its column are in one layer: Targets.

The switch, the faceplace, and their column are in another layer: Switches.

With all layers visible, you can see the connecting line from the switch to the light.

If you hide the Default layer, the connecting line disappears.

If you unhide the Default layer, the connecting line reappears.
TagsNo tags attached.

Relationships

related to 0005087 resolvedgreebo Connecting lines to targeted entities don't show up if 'Default' layer was hidden 

Activities

grayman

grayman

19.09.2016 18:32

administrator  

connectors.map (7,465 bytes)   
Version 2
// entity 0
{
"classname" "worldspawn"
"editor_drLastCameraPos" "133.937 15.4567 113.278"
"editor_drLastCameraAngle" "-16.2 51.3 0"
"editor_drMapPos1" "145.117 609.786 279.045"
"editor_drMapAngle1" "-48 150.8 0"
"editor_drMapPos2" "414.798 255.441 -264.933"
"editor_drMapAngle2" "2.10002 84.5976 0"
"editor_drMapPos3" "-749.97 -1606.21 -470.066"
"editor_drMapAngle3" "-3.29998 6.59757 0"
"editor_drMapPos4" "1014.05 -953.679 -556.857"
"editor_drMapAngle4" "-10.2 355.498 0"
"editor_drMapPos5" "987.599 3513.79 -319.877"
"editor_drMapAngle5" "-61.1999 172.198 0"
"editor_drMapPos6" "-1032.5 -2840 739.5"
"editor_drMapAngle6" "-77.0999 175.798 0"
"editor_drMapPos7" "952.822 285.005 1366.04"
"editor_drMapAngle7" "-74.8 149.373 0"
"editor_drMapPos8" "976 424 320"
"editor_drMapAngle8" "-3 15.3467 0"
"editor_drMapPos9" "409.146 547.464 392.83"
"editor_drMapAngle9" "-16.8 284.947 0"
// primitive 0
{
brushDef3
{
( 0 0 1 -200 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 1 0 -512 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0.0625 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 1 0 0 -512 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0.0625 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 -1 0 0 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0.0625 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( -1 0 0 0 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0.0625 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 0 -1 192 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
}
}
// primitive 1
{
brushDef3
{
( 0 0 1 -192 ) ( ( 0.0078125 0 255.9375 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 1 0 -520 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 1 0 0 -512 ) ( ( 0.0078125 0 255.9375 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 0 -1 0 ) ( ( 0.0078125 0 255.9375 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( -1 0 0 0 ) ( ( 0.0078125 0 0.0625 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 -1 0 512 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
}
}
// primitive 2
{
brushDef3
{
( 0 0 1 -192 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 255.9375 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 1 0 -512 ) ( ( 0.0078125 0 0.0625 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 1 0 0 -520 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 0 -1 0 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0.0625 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 -1 0 0 ) ( ( 0.0078125 0 255.9375 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( -1 0 0 512 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
}
}
// primitive 3
{
brushDef3
{
( 0 1 0 -512 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 255.9375 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 1 0 0 -512 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 255.9375 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 0 -1 -8 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 -1 0 0 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 255.9375 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( -1 0 0 0 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 255.9375 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 0 1 0 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
}
}
// primitive 4
{
brushDef3
{
( 0 0 1 -192 ) ( ( 0.0078125 0 0.0625 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 1 0 0 -512 ) ( ( 0.0078125 0 0.0625 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 0 -1 0 ) ( ( 0.0078125 0 0.0625 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 -1 0 -8 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( -1 0 0 0 ) ( ( 0.0078125 0 255.9375 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 1 0 0 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
}
}
// primitive 5
{
brushDef3
{
( 0 0 1 -192 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0.0625 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 1 0 -512 ) ( ( 0.0078125 0 255.9375 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 0 -1 0 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 255.9375 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 -1 0 0 ) ( ( 0.0078125 0 0.0625 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( -1 0 0 -8 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 1 0 0 0 ) ( ( 0.0078125 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
}
}
// primitive 6
{
brushDef3
{
( 0 0 1 -192 ) ( ( 0.00390625 0 0 ) ( 0 0.00390625 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 1 0 -144 ) ( ( 0.00390625 0 0 ) ( 0 0.00390625 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 1 0 0 -208 ) ( ( 0.00390625 0 0 ) ( 0 0.00390625 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 0 -1 0 ) ( ( 0.00390625 0 0 ) ( 0 0.00390625 255.9375 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 -1 0 128 ) ( ( 0.00390625 0 0 ) ( 0 0.00390625 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( -1 0 0 176 ) ( ( 0.00390625 0 0 ) ( 0 0.00390625 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
}
}
// primitive 7
{
brushDef3
{
( 0 0 1 -192 ) ( ( 0.00390625 0 0 ) ( 0 0.00390625 255.75 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 1 0 -144 ) ( ( 0.00390625 0 0.25 ) ( 0 0.00390625 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 1 0 0 -272 ) ( ( 0.00390625 0 0 ) ( 0 0.00390625 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 0 -1 0 ) ( ( 0.00390625 0 0 ) ( 0 0.00390625 0.1875 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( 0 -1 0 128 ) ( ( 0.00390625 0 255.75 ) ( 0 0.00390625 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
( -1 0 0 240 ) ( ( 0.00390625 0 0 ) ( 0 0.00390625 0 ) ) "textures/darkmod/carpet/rugs/ornate_vines" 0 0 0
}
}
}
// entity 1
{
"classname" "atdm:ambient_world"
"name" "ambient_world"
"origin" "256 256 96"
"light_center" "0 0 0"
"light_radius" "320 320 320"
"_color" "0.08 0.08 0.08"
}
// entity 2
{
"classname" "info_player_start"
"name" "info_player_start_1"
"origin" "256 56 0"
"angle" "90"
}
// entity 3
{
"classname" "atdm:lamp_electric_fancy_lit"
"name" "atdm_lamp_electric_fancy_lit_1"
"origin" "192 128 96"
"light_center" "-16 0 -4"
"light_radius" "260 260 260"
"model" "models/darkmod/lights/non-extinguishable/electric_wall_fancy.lwo"
"rotation" "0 1 0 -1 0 0 0 0 1"
}
// entity 4
{
"classname" "func_static"
"name" "func_static_1"
"origin" "256 125.375 48"
"rotation" "1 0 0 0 1 0 0 0 1"
"model" "models/darkmod/mechanical/switches/switch_flip_backplate.ase"
}
// entity 5
{
"classname" "atdm:switch_flip"
"name" "atdm_switch_flip_1"
"origin" "256 125.375 48"
"rotation" "1 0 0 0 1 0 0 0 1"
"rotate" "0 0 45"
"target0" "atdm_lamp_electric_fancy_lit_1"
}
connectors.map (7,465 bytes)   
greebo

greebo

19.09.2016 18:35

administrator   ~0008323

Last edited: 19.09.2016 18:39

View 2 revisions

The layers are stored in the .darkradiant file, do you still have it by chance?

Because I tried to create these layers myself and I couldn't see the issue.

grayman

grayman

19.09.2016 18:42

administrator  

grayman

grayman

19.09.2016 18:42

administrator   ~0008324

Ooops. Sorry. Attached.
greebo

greebo

19.09.2016 18:45

administrator   ~0008326

Thanks for the .darkradiant file, but I still can't see it happening. It does happen to you if you load the map afresh, doesn't it?
grayman

grayman

19.09.2016 18:50

administrator   ~0008328

Last edited: 19.09.2016 18:50

View 2 revisions

If I kill DR and restart and open the map, the problem goes away.

So it only happens during the session where the connections are made.

You should be able to replicate it by creating a new set of columns and a light and a switch faceplate and a switch. Put the new light and its column into "Targets", put the new switch, faceplace, and column into "Switches".

Then target the new switch to the new light.

Then hide the "Default" layer and the new connecting line should go away.

Unhide "Default" and the line should reappear.

greebo

greebo

20.09.2016 04:53

administrator   ~0008332

Confirmed, I see what's going on, and it happens in 2.0.4 as well. I'll update the issue information and see to it.
greebo

greebo

20.09.2016 05:11

administrator   ~0008333

Fixed in b8a41b837a82a87430f8499df8ba653f672318bd
grayman

grayman

25.09.2016 15:12

administrator   ~0008345

Assuming this is fixed in 2.05 pre5 (Sep 25 build) ...

Using connectors.map ...

If I show all layers, then hide Default, the connecting line from the switch to the light remains visible (Good).

However ...

Leave Default hidden ...

Duplicate the columns, the light, and the backplate, and paste them nearby. (Don't duplicate the switch.)

Duplicate the switch and place the new switch on the new backplate. It has a connecting line to the old light.

Deselect the new switch and the connecting line disappears.

If I select the switch, the line reappears.

If I unhide Default ...

The connecting line stays visible, whether the new switch is selected or not.

So the problem remains, but in a different form.
greebo

greebo

09.10.2016 08:23

administrator   ~0008372

Confirmed, the cause was a completely different part of the code though. Thanks for spotting, fixed in c29c98c9b7258845fae9739e6443c0152e378e98

Issue History

Date Modified Username Field Change
19.09.2016 18:32 grayman New Issue
19.09.2016 18:32 grayman Status new => assigned
19.09.2016 18:32 grayman Assigned To => greebo
19.09.2016 18:32 grayman File Added: connectors.map
19.09.2016 18:35 greebo Note Added: 0008323
19.09.2016 18:39 greebo Note Edited: 0008323 View Revisions
19.09.2016 18:42 grayman File Added: connectors.darkradiant
19.09.2016 18:42 grayman Note Added: 0008324
19.09.2016 18:45 greebo Note Added: 0008326
19.09.2016 18:50 grayman Note Added: 0008328
19.09.2016 18:50 grayman Note Edited: 0008328 View Revisions
20.09.2016 04:53 greebo Note Added: 0008332
20.09.2016 04:53 greebo Product Version 2.1.0 => 2.0.4
20.09.2016 04:53 greebo Target Version => 2.1.0
20.09.2016 04:53 greebo Summary Connecting lines toggling on/off => Connecting lines are created in Default layer
20.09.2016 05:11 greebo Note Added: 0008333
20.09.2016 05:11 greebo Status assigned => resolved
20.09.2016 05:11 greebo Fixed in Version => 2.1.0
20.09.2016 05:11 greebo Resolution open => fixed
25.09.2016 15:12 grayman Note Added: 0008345
25.09.2016 15:13 grayman Status resolved => feedback
25.09.2016 15:13 grayman Resolution fixed => reopened
09.10.2016 08:23 greebo Note Added: 0008372
09.10.2016 08:23 greebo Status feedback => resolved
09.10.2016 08:23 greebo Resolution reopened => fixed
07.07.2017 18:51 greebo Status resolved => closed
30.12.2019 07:46 greebo Relationship added related to 0005087