View Issue Details

IDProjectCategoryView StatusLast Update
0004386DarkRadiantMap Editingpublic04.01.2021 11:48
ReporterSpooks Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionreopened 
OSWindowsOS Version7 
Product Version2.1.0 
Target Version2.1.0Fixed in Version2.1.0 
Summary0004386: Projected lights don't rotate around their origin anymore
DescriptionHappening on the latest DarkRadiant 2.0.5 prerelease build. Does not happen on 2.0.4.
Steps To ReproduceMake a light.
Go into light properties and turn it from an Omni to a Projected light.
Bring up the rotation widget and you can see it is centered in the centre of the light volume rather than the light origin.
TagsNo tags attached.

Relationships

related to 0004578 closedgreebo Multiselection with lights offsets the rotation origin 
related to 0005484 resolvedgreebo Projected lights don't rotate around their origin anymore 

Activities

greebo

greebo

25.09.2016 10:28

administrator   ~0008344

While the problem can be circumvented by activating the "Rotate func_* entities around origin" option in the top toolbar, the deactivated setting produced weird results, so I added code to always use the light's origin as rotation pivot (provided a single light entity is selected in the first place).
Spooks

Spooks

28.12.2020 12:51

reporter   ~0013301

Well, hello there. Time to reopen this old bug from 2016, as it has appeared again in DR 2.10. Same thing, including the "Rotate func_* entities around origin" caveat in greebo's note. Tested in an old installation, 2.9.0 pre3, and the problem is not present there.
greebo

greebo

04.01.2021 11:48

administrator   ~0013362

Last edited: 04.01.2021 11:48

View 2 revisions

I've opened a new issue report for it: 0005484

Issue History

Date Modified Username Field Change
25.09.2016 08:41 Spooks New Issue
25.09.2016 08:45 greebo Status new => confirmed
25.09.2016 08:45 greebo Product Version => 2.1.0
25.09.2016 10:28 greebo Note Added: 0008344
25.09.2016 10:28 greebo Status confirmed => resolved
25.09.2016 10:28 greebo Fixed in Version => 2.1.0
25.09.2016 10:28 greebo Resolution open => fixed
25.09.2016 10:28 greebo Assigned To => greebo
25.09.2016 10:28 greebo Target Version => 2.1.0
07.07.2017 18:51 greebo Status resolved => closed
19.07.2017 16:29 Spooks Relationship added related to 0004578
28.12.2020 12:51 Spooks Status closed => assigned
28.12.2020 12:51 Spooks Resolution fixed => reopened
28.12.2020 12:51 Spooks Note Added: 0013301
04.01.2021 11:47 greebo Issue cloned: 0005484
04.01.2021 11:47 greebo Relationship added related to 0005484
04.01.2021 11:48 greebo Status assigned => closed
04.01.2021 11:48 greebo Note Added: 0013362
04.01.2021 11:48 greebo Note Edited: 0013362 View Revisions