View Issue Details

IDProjectCategoryView StatusLast Update
0004387DarkRadiantSelection Systempublic07.07.2017 18:51
ReporterSpooks Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilitysometimes
Status closedResolutionfixed 
OSWindowsOS Version7 
Product Version2.1.0 
Target Version2.1.0Fixed in Version2.1.0 
Summary0004387: Invert Selection problems
DescriptionIn 2.0.4 Invert Selection works like this: you select an object, press I then everything but that object gets selected.

In 2.0.5 pre5 Invert Selection now
a) does not ACTUALLY invert the selection, rather it selects all
b) it disregards hidden layers and objects manually hidden by H
c) it takes multiple presses of the I button, with each press cycling through weird selection criteria before it returns to your original selection.
TagsNo tags attached.

Relationships

related to 0002141 closedgreebo Invert Selection includes worldspawn 

Activities

greebo

greebo

15.10.2016 16:58

administrator   ~0008375

I'm currently trying to narrow down what the problematic cases are. Can you maybe send me a .map including the .darkradiant file and describe some use cases that are not working anymore? That would be helpful.
Spooks

Spooks

18.10.2016 20:41

reporter   ~0008380

Last edited: 18.10.2016 20:46

View 2 revisions

Okay, I've tried to be more rigorous and I've attempted several scenarios and I have a better idea when invert selection fails now. I've uploaded a map with .darkradiant file in tow which exhibits the problem.

When the map opens, select any of the brushes and press "I" a couple of times - Invert Selection should work fine. Then, hide the Default layer and select any of the brushes left - pressing "I" will no longer give the same result.

It doesn't matter how you select the brushes: 3D or 2D viewport, directly or by clicking a layer name. It looks like a layer issue but I'm fairly sure it's not Default Layer itself that's doing this. In my actual WIP, the layer which contains the caulk that is used to seal the map is the one that messes up Invert Selection if it is hidden.

Edit: The map was created in pre5, but the problem carries over in pre6. It's also very hard for me to reproduce this behavior consistently.

Spooks

Spooks

18.10.2016 20:41

reporter  

selection_problems.zip (1,407 bytes)
greebo

greebo

19.10.2016 17:23

administrator   ~0008382

Thanks, I can see the problematic behaviour.
greebo

greebo

22.10.2016 16:46

administrator   ~0008386

It appears that 2.0.4 has problems too when the worldspawn entity is not visible (i.e. hidden by a layer), although the problems doesn't manifest itself as weird as in 2.0.5.

I'll have to go through that InvertSelection code, the algorithm could use some work anyway.
greebo

greebo

29.10.2016 06:53

administrator   ~0008402

Rewrote the invert selection algorithm; fixed in 42229aa9d70ca688fa6037fe55e06d8fe0e3c855.

Issue History

Date Modified Username Field Change
25.09.2016 16:00 Spooks New Issue
25.09.2016 16:01 Spooks Category Map Editing => Selection System
25.09.2016 18:36 greebo Status new => acknowledged
09.10.2016 14:18 greebo Status acknowledged => confirmed
15.10.2016 16:58 greebo Note Added: 0008375
15.10.2016 16:58 greebo Status confirmed => feedback
18.10.2016 20:41 Spooks Note Added: 0008380
18.10.2016 20:41 Spooks Status feedback => new
18.10.2016 20:41 Spooks File Added: selection_problems.zip
18.10.2016 20:46 Spooks Note Edited: 0008380 View Revisions
18.10.2016 22:00 Spooks Reproducibility always => sometimes
19.10.2016 17:23 greebo Note Added: 0008382
19.10.2016 17:23 greebo Assigned To => greebo
19.10.2016 17:23 greebo Status new => confirmed
22.10.2016 16:44 greebo Relationship added related to 0002141
22.10.2016 16:46 greebo Note Added: 0008386
29.10.2016 06:52 greebo Product Version => 2.1.0
29.10.2016 06:52 greebo Target Version => 2.1.0
29.10.2016 06:53 greebo Note Added: 0008402
29.10.2016 06:53 greebo Status confirmed => resolved
29.10.2016 06:53 greebo Fixed in Version => 2.1.0
29.10.2016 06:53 greebo Resolution open => fixed
07.07.2017 18:51 greebo Status resolved => closed