View Issue Details

IDProjectCategoryView StatusLast Update
0004407DarkRadiantDesign/Codingpublic07.07.2017 18:51
Reportermhoes Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSLinuxOS VersionFedora 26
Product Version2.1.0 
Target Version2.1.0Fixed in Version2.1.0 
Summary0004407: build error using latest git
DescriptionHi,


When trying to build the code with the latest git version (commit ef4b46d315614dbc67dc173bd2d1b1952de33c40, 2016-10-30 09:17:45 +0100) on fedora 24 and gcc 6.2.1, I now get the following error:


Making all in scene
make[3]: Entering directory '/home/maarten/src/darkradiant/libs/scene'
  CXX SelectableNode.lo
In file included from /usr/include/c++/6.2.1/memory:62:0,
                 from ../../include/Bounded.h:4,
                 from ../../include/inode.h:3,
                 from ../../libs/scene/Node.h:3,
                 from SelectableNode.h:3,
                 from SelectableNode.cpp:1:
/usr/include/c++/6.2.1/bits/stl_algobase.h: In instantiation of ‘bool std::equal(_IIter1, _IIter1, _IIter2, _BinaryPredicate) [with _IIter1 = __gnu_cxx::__normal_iterator<long unsigned int*, std::vector<long unsigned int> >; _IIter2 = __gnu_cxx::__normal_iterator<long unsigned int*, std::vector<long unsigned int> >; _BinaryPredicate = __gnu_cxx::__normal_iterator<long unsigned int*, std::vector<long unsigned int> >]’:
SelectableNode.cpp:198:2: required from here
/usr/include/c++/6.2.1/bits/stl_algobase.h:1082:25: error: no match for call to ‘(__gnu_cxx::__normal_iterator<long unsigned int*, std::vector<long unsigned int> >) (long unsigned int&, long unsigned int&)’
  if (!bool(__binary_pred(*__first1, *__first2)))
            ~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~
Makefile:521: recipe for target 'SelectableNode.lo' failed
make[3]: *** [SelectableNode.lo] Error 1
make[3]: Leaving directory '/home/maarten/src/darkradiant/libs/scene'
Makefile:437: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/home/maarten/src/darkradiant/libs'
Makefile:752: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/maarten/src/darkradiant'
Makefile:493: recipe for target 'all' failed
make: *** [all] Error 2
Steps To Reproduce$ make clean
$ ./autogen.sh
$ ./configure --enable-debug --enable-darkmod-plugins
$ make
TagsNo tags attached.

Activities

greebo

greebo

30.10.2016 09:35

administrator   ~0008408

Ah, the std::equal overload I've been using is a C++14 standards function, I've changed to use the older standard C++ overload. Fixed in 97ddec506ef8ca70cd9c2ea0e69d01e39d2d5a39, let's hope.
mhoes

mhoes

30.10.2016 09:45

reporter   ~0008409

Yes, that solves the issue: 'Making all in scene' now completes without the error. However, I now run into a new build failure. Not sure if to report it here, or to open a new bug report for it ? Anyway, here's the error :


Making all in wxutil
make[3]: Entering directory '/home/maarten/src/darkradiant/libs/wxutil'
  CXX ConsoleView.lo
  CXX FreezePointer.lo
  CXX GLWidget.lo
  CXX KeyValueTable.lo
  CXX PanedPosition.lo
  CXX VFSTreePopulator.lo
  CXX WindowPosition.lo
  CXX window/TransientWindow.lo
  CXX dialog/Dialog.lo
  CXX dialog/MessageBox.lo
  CXX preview/ModelPreview.lo
In file included from /usr/include/X11/Xlib.h:44:0,
                 from /usr/include/GL/glx.h:30,
                 from /usr/include/wx-3.0/wx/unix/glx11.h:13,
                 from /usr/include/wx-3.0/wx/gtk/glcanvas.h:14,
                 from /usr/include/wx-3.0/wx/glcanvas.h:192,
                 from preview/../GLWidget.h:6,
                 from preview/ModelPreview.cpp:2:
../../libs/scene/BasicRootNode.h: In member function ‘virtual std::size_t scene::BasicRootNode::getHighlightFlags()’:
../../libs/scene/BasicRootNode.h:69:27: error: expected unqualified-id before numeric constant
         return Highlight::None; // never highlighted
                           ^
../../libs/scene/BasicRootNode.h:69:27: error: expected ‘;’ before numeric constant
In file included from preview/ModelPreview.cpp:14:0:
../../libs/scene/BasicRootNode.h:69:31: warning: statement has no effect [-Wunused-value]
         return Highlight::None; // never highlighted
                               ^
Makefile:641: recipe for target 'preview/ModelPreview.lo' failed
make[3]: *** [preview/ModelPreview.lo] Error 1
make[3]: Leaving directory '/home/maarten/src/darkradiant/libs/wxutil'
Makefile:437: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/home/maarten/src/darkradiant/libs'
Makefile:752: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/maarten/src/darkradiant'
Makefile:493: recipe for target 'all' failed
make: *** [all] Error 2
greebo

greebo

06.11.2016 13:40

administrator   ~0008442

Should be ok in 3fc78892c30f9b6110d7696a0163b084385493bf
mhoes

mhoes

06.11.2016 14:21

reporter   ~0008443

Hi,

Thanks, the build completes without errors now !


(small note, maybe im wrong:

although im certainly no expert on the matter, i took a look at the changed files and noticed some 'Makefile.in' files in the repository. i always assumed that these were automatically created based on 'Makefile.am', and should not be in the repo ? 'git pull' complained about local changes to these files when i tried to pull the latest; i didnt manually edited any of them. git complained about some other files too, which may or may not belong in the repo, as they may be created automatically by running autogen.sh ?



$ git pull
remote: Counting objects: 565, done.
remote: Compressing objects: 100% (90/90), done.
remote: Total 565 (delta 386), reused 363 (delta 363), pack-reused 112
Receiving objects: 100% (565/565), 255.53 KiB | 0 bytes/s, done.
Resolving deltas: 100% (420/420), completed with 152 local objects.
From git://github.com/codereader/DarkRadiant
   4007859..3fc7889 master -> origin/master
   5fe79e0..546d645 grouping -> origin/grouping
Updating 4007859..3fc7889
error: Your local changes to the following files would be overwritten by merge:
        Makefile.in
        aclocal.m4
        configure
        libs/Makefile.in
        libs/ddslib/Makefile.in
        libs/math/Makefile.in
        libs/picomodel/Makefile.in
        libs/scene/Makefile.in
        libs/wxutil/Makefile.in
        libs/xmlutil/Makefile.in
        ltmain.sh
        m4/libtool.m4
        plugins/Makefile.in
        plugins/archivezip/Makefile.in
        plugins/commandsystem/Makefile.in
        plugins/dm.conversation/Makefile.in
        plugins/dm.difficulty/Makefile.in
        plugins/dm.editing/Makefile.in
        plugins/dm.gui/Makefile.in
        plugins/dm.objectives/Makefile.in
        plugins/dm.stimresponse/Makefile.in
        plugins/eclassmgr/Makefile.in
        plugins/eclasstree/Makefile.in
        plugins/entity/Makefile.in
        plugins/entitylist/Makefile.in
        plugins/eventmanager/Makefile.in
        plugins/filetypes/Makefile.in
        plugins/filters/Makefile.in
        plugins/fonts/Makefile.in
        plugins/grid/Makefile.in
        plugins/image/Makefile.in
        plugins/mapdoom3/Makefile.in
        plugins/md5model/Makefile.in
        plugins/model/Makefile.in
        plugins/particles/Makefile.in
        plugins/scenegraph/Makefile.in
        plugins/script/Makefile.in
        plugins/shaders/Makefile.in
        plugins/skins/Makefile.in
        plugins/sound/Makefile.in
        plugins/uimanager/Makefile.in
        plugins/undo/Makefile.in
        plugins/vfspk3/Makefile.in
        plugins/xmlregistry/Makefile.in
        radiant/Makefile.in
mhoes

mhoes

06.11.2016 14:26

reporter   ~0008444

did a quick google; looks like im right about at least the Makefile.in'

https://www.gnu.org/software/automake/manual/automake.html#automake-Invocation
greebo

greebo

06.11.2016 17:16

administrator   ~0008446

I'm not an automake expert, I was just following the steps OrbWeaver made, and he decided to checkin the .in files.
mhoes

mhoes

07.11.2016 09:23

reporter   ~0008447

alright, point taken. im no automake expert myself; i just did a quick google and looked at some of the documentation of automake like the link posted earlier, and thought it might need some looking into.

anyway, the code now builds without errors, so i guess that means this bug can be closed now. thanks again !

Issue History

Date Modified Username Field Change
30.10.2016 08:42 mhoes New Issue
30.10.2016 09:34 greebo Product Version 2.0.4 => 2.1.0
30.10.2016 09:34 greebo Target Version => 2.1.0
30.10.2016 09:34 greebo Steps to Reproduce Updated View Revisions
30.10.2016 09:34 greebo Assigned To => greebo
30.10.2016 09:34 greebo Status new => assigned
30.10.2016 09:35 greebo Note Added: 0008408
30.10.2016 09:35 greebo Status assigned => resolved
30.10.2016 09:35 greebo Fixed in Version => 2.1.0
30.10.2016 09:35 greebo Resolution open => fixed
30.10.2016 09:45 mhoes Note Added: 0008409
06.11.2016 13:05 greebo Status resolved => assigned
06.11.2016 13:05 greebo Resolution fixed => reopened
06.11.2016 13:40 greebo Note Added: 0008442
06.11.2016 13:40 greebo Status assigned => resolved
06.11.2016 13:40 greebo Resolution reopened => fixed
06.11.2016 14:21 mhoes Note Added: 0008443
06.11.2016 14:26 mhoes Note Added: 0008444
06.11.2016 17:16 greebo Note Added: 0008446
07.11.2016 09:23 mhoes Note Added: 0008447
07.07.2017 18:51 greebo Status resolved => closed