View Issue Details

IDProjectCategoryView StatusLast Update
0004412The Dark ModAIpublic06.12.2018 21:34
Reportergrayman Assigned Tograyman  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionTDM 2.04 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004412: WIP Fire Elemental
DescriptionIntroduce Fire Elemental.
TagsNo tags attached.

Activities

grayman

grayman

15.11.2016 16:43

administrator   ~0008485

Make the Fire Elemental work.

Rev. 6672:

Actor.cpp
Entity.cpp
Player.cpp
Projectile.cpp
ProjectileResult.cpp
AAS.h
AAS_debug.cpp
AAS_local.cpp
AAS_pathing.cpp
AAS_routing.cpp
AI.cpp
AI.h
AI_pathing.cpp
CombatTask.cpp
CombatTask.h
FollowActorTask.cpp
RangedCombatTask.cpp
AASCluster.cpp
AASFile.h

Rev. 14635:

tdm_ai_base.def
tdm_ai_monster_elemental.def
tdm_ai_vocal_set_monster_elemental.def
tdm_weapon_fireball.def
tdm_elemental.prt
tdm_ai_base.script
tdm_ai_monster_elemental.script
tdm_ai_monster_elemental.sndshd
voices/monster/elemental/*
grayman

grayman

15.11.2016 16:44

administrator   ~0008486

This is a WIP, so I'm leaving it open against 2.06.

It should be usable in 2.05, but mappers should be told it's subject to changes in behavior or look.
grayman

grayman

16.09.2017 18:36

administrator   ~0009262

Continue as WIP for 2.07.

There have been no suggested changes for 2.06.
grayman

grayman

03.12.2018 17:42

administrator   ~0010814

No suggested changes for 2.07 (Don't think it's been used much), so I'm marking it resolved.
VanishedOne

VanishedOne

05.12.2018 21:18

developer   ~0010828

Actually there was one thing I was going to raise, but I'd intended to do more checking first: it seems fire elementals can burn each other. What I suspect is happening is that if they get close enough, they'll respond to each other's damage stims: I trapped a pair in a cage and they fought to the eventual death (or tried to; I think they absorb each other's projectiles, meaning only the stims would have any effect, and they have a lot of health so it took ages for one to die).

I'm not sure how big a problem this is in practice, i.e. how likely they are to get into proximity.

This arises - I suspect - because notionally fire elementals do fire/burning damage, but in fact they do generic damage, and they inherit the usual response to the generic damage stim. (And of course the usual way for mappers to make damaging fire is with a damage stim or a trigger_hurt.) I saw an old thread once in which someone said that giving players and AI damage responses for STIM_FIRE was considered and rejected because of concerns about them burning themselves on candles, etc. I suppose something like making the response script apply damage only above a chosen stim magniture wasn't considered worth the effort back then.
grayman

grayman

06.12.2018 03:07

administrator   ~0010829

I suppose it's safe to turn off the stim response to DAMAGE.

Why did your elementals fight each other? Did you put them on different teams? They default to team 15, and are friendly to each other.
VanishedOne

VanishedOne

06.12.2018 15:32

developer   ~0010834

They're both on team 0, so that they don't attack me while I observe. If I put a non-civilian AI on team 0, and then wound him with my sword, he attacks me back, so I suppose self-defence overrides the team system.

(On the subject of FE responses, I'm wondering whether the holy response is needed, since holy water arrow results still have water stims.)
grayman

grayman

06.12.2018 21:29

administrator   ~0010842

Tested with holy water stim turned off, and it works fine. Thanks for the catch.
grayman

grayman

06.12.2018 21:34

administrator   ~0010843

Rev 15412 covers both the DAMAGE and HOLY WATER changes.

Issue History

Date Modified Username Field Change
06.11.2016 14:57 grayman New Issue
06.11.2016 14:57 grayman Status new => assigned
06.11.2016 14:57 grayman Assigned To => grayman
15.11.2016 16:43 grayman Note Added: 0008485
15.11.2016 16:44 grayman Note Added: 0008486
16.09.2017 18:36 grayman Note Added: 0009262
16.09.2017 18:36 grayman Target Version TDM 2.06 => TDM 2.07
03.12.2018 17:42 grayman Note Added: 0010814
03.12.2018 17:44 grayman Status assigned => resolved
03.12.2018 17:44 grayman Resolution open => fixed
03.12.2018 17:44 grayman Fixed in Version => TDM 2.07
05.12.2018 21:18 VanishedOne Note Added: 0010828
06.12.2018 03:07 grayman Note Added: 0010829
06.12.2018 15:32 VanishedOne Note Added: 0010834
06.12.2018 21:29 grayman Note Added: 0010842
06.12.2018 21:34 grayman Note Added: 0010843